Zwift doesn't upload some rides to Garmin Connect

Happened twice over the past two weeks:

  • first time Zwift didn’t upload single ride to Garmin Connect at all.
  • second time I did three rides in succession (warmup, race, cooldown), but Zwift only uploaded the first one, but not the others.

In total, 3 out of 14 rides didn’t upload.

If any rides were under 2km distance, that could be the reason.

Upload to Garmin has been very slow recently. All mine have eventually made it to Garmin after a while…

All rides that failed to upload were >2km, e.g. today’s race was 36km.

@Kat you may be right - I see that the race just appeared in G.Connect, more than 1.5 hrs after it is over. But earlier ride never appeared.

Not working for me tonight either. Have tried deleting and repairing the connection between the two platforms and ride data still doesn’t want to push from Zwift to Garmin. No recent issues with the connection until today.

Failed for me again yesterday for a 60km ride.
I waited until today, but the ride never appeared.

I use recovery and training guidance from Garmin a lot, and those missing rides really mess it up.

And again today. That’s a shame really.

Unpair Zwift and GC syncing then reconnect the two accounts. No idea why but re-establishing the connection has worked for me in the past. It won’t upload the rides that didn’t in the past but should fix it for future activities.

Thanks, will try that and report back.

I disconnected and then reconnected accounts. Frist ride after that did sync to G.Connect, but the one from yesterday didn’t. Any other suggestions?

If you can find the relevant .fit file on your PC/Mac (assuming that’s what you used) then you can import that to Garmin Connect directly.

This is the bug that keeps me from renewing my subscription. But this morning I found out what’s happening with me. It’s my new laptop …I cranked up my old 10 year old i7 980m Nvida laptop and it was working fine. Except I can’t run 4k to my TV… Which is why I bought a new laptop. Zwift please fix it so the

CPU: AMD Ryzen 9 5980HX with Radeon Graphics
Graphics: AMD Radeon RX 6800M
Windows 11 Home
Memory: 64 gigs
Will run your game
Anyone else running AMD here?

Colin, thanks, I did try that, but unfortunately Garmin doesn’t use these manually uploaded .fit files to calculate recovery and training load metrics. Plus it’s a bit of hassle to do it manually every time.

Ah yes. That’s an issue. I was just thinking about how to get one file you’d lost rather than as an ongoing thing. I appreciate it’s even more hassle, but you can use a utility at to change the device type to a Garmin before you import it to Connect and it’ll then be taken into account properly in Training Status.

Ha, I didn’t realize why Garmin doesn’t consider these files for the metrics.
Anyway, it would be easier for everyone if Zwift just figured out what’s wrong with the upload.

For sure.

Normally, my uploads happen almost instantly. I think I had to “renew” the Zwift/Garmin link once in the past 12 months - simply by disabling it for a while, and then enabling it again.

Do you upload to Strava at all? It would be interesting to see if your fit file made it through to there unscathed.

I do upload to Strava, no issues there whatsoever. Every Zwift ride successfully makes its way there.