Intermittent Problem - Not uploading to Garmin Connect

I have been using Garmin Connect and Strava both connected to Zwift for several years, no issues.
My ride on Monday didn’t sync to Connect, though it did go to Strava and services connected to Strava (
Didn’t think it was a big thing, but someone else mentioned that they’ve had the same issue, but not for just one workout, I don’t think.

I’ve been seeing this problem as well – been riding daily on Zwift all week but none of the sessions have uploaded to Garmin Connect, and saving a .fit file and uploading it manually returns an error.

I’m assuming the issue is on Garmin’s end, but any debug help would be appreciated.

Garmin support says it is operating as normal, try disconnecting and reconnection from Zwift?

It works fine for last 2 rides for me, it just skipped one - and when I download the .fit file, it won’t upload to Garmin. I don’t think there’s any point in disconnecting and re-connecting, because it works now. I posted this because I’m suspicious that problems that some people think are ‘fixed’ by disconnecting and reconnecting are actually just something that goes wrong sometimes.

I eventually narrowed it down to this: if you save the Garmin activity before the Zwift activity, Zwift tries to send the data over to Garmin Connect but Garmin says “wait, no, I already have an activity during this time window” and it rejects it.

If you save the Zwift activity before you save the Garmin activity, both activities save to Garmin Connect just fine.

Hmmm… I wasn’t dual recording, so probably doesn’t match up with my failure.

Hi there, having the same issue. Disconnected and tried to reconnect - but now Garmin won’t connect back with Zwift. Any thoughts?