Garmin Connect upload

I can’t upload my zwift rides to Garmin connect.
Iguess this is a Garmin issue.
Any suggestions?

Try disconnecting & reconnecting your Garmin & Zwift accounts.

In my experience, Garmin will almost always blame the third party when it comes to integration problems.

Allready done. Still doesn’t work

I have the Same Problem since i have connected TrainingPeaks.

I have sporadic issues with my Zwift rides connecting to Garmin Connect and MyFItnessPal applications.

I have uninstalled all of the apps and then reinstalled, but my ride from today 1/31/20 is not showing up in Garmin Connect or MyFitnessPal.

When my Zwift rides do connect to Garmin Connect the calories expended do not show up correctly in MyFitnessPal.

Does not make sense…

All my rides have been syncing but as of 30 Jan they are not syncing with Garmin connect. Thats 2 rides now. I have disconnected and reconnected multiple times, uninstalled reinstalled the Garmin app. Used a desktop browser to disconnected Zwift, Strava, Mapmyfitness, Withings and Garmin and then reconnected them all but still no Garmin sync but the other apps are all connecting (API is good). I have downloaded the file from Training Peaks and this won’t be accepted when trying to upload manually to Garmin connect via a desktop browser. So it seems at this stage it’s a Garmin problem as usual. However the Withings weight and body composition data is syncing. Anyone else having this problem?

Same problem!
No sync to Garmin from my ride yesterday

1 Like

My Zwift ride from yesterday finally synced to Garmin Connect after about 8 -10 hours.

this should be fixed mine uploaded fine today

Anyone else having issues again? Garmin is not showing Zwift activities from the past 48 hours but a manual upload fails with the error that the activity already exists. If I follow the link suggested to the already uploaded activity, I get an error " Sorry, we’re having trouble with this page". So I guess the problem is at Garmin’s end?