Zwift not uploading to strava and garmin connect

Since four days Zwift is not uploading my rides to Strava and Garmin. I tried to do that manually but cannot reach the fit file even though my rides are listed on the main activities list of the

Hi @SINAN_AVCI welcome to Zwift forums.

Have you tried disconnecting / reconnecting to Strava and Garmin? Sometimes that can reset the connection and get it to work again.
Here are the instructions.

Several weeks ago, we had many Zwifters reporting an error w/ Garmin Connect that turned out to be something on Garmin’s end. It got resolved within half a day. This time - yours is the only report so far, but I’ll keep an eye out for more reports.

1 Like

The problem is not only with Garmin but also with Strava. Zwift did not upload two of my rides and the distance of the rides on Zwift site are also wrong. Yesterday I rode once again and this time the ride was uploaded without a problem. Looks like a temporary problem with the Zwift servers

Hi @shooj & @SINAN_AVCI same issue here with my account. Last Upload was on Feb 28th, since then my last two workouts (March 2nd & 3rd) haven’t been uploaded to Garmin Connect. Uploading via fit-file ended with error “file has already been uploaded”. Disconnecting Zwift from GC and connecting again got me nothing, issues still exist. Uploads to TrainingPeaks and Strava worked well.