Auto Upload to Garmin Connect fails

Anyone else experiencing this?

Did a 15 minute warmup - uploaded to Strava, Garmin Connect and Training Peaks fine.

Did a 100 minute meet-up + workout - it made it to Strava and TP but not to Garmin Connect.

Tried manually too:

Uploaded the .fit file from Zwift to GC (always worked in the past) and it just errors. Same with the file from Strava.

Still on trial period. Comparing to Peloton $13/month. Like the idea of exporting finished data to Strava & Garmin. Set it up yet not working. Also was trying to figure a way to attach Garmin Sensors to my new indoor spinner. IC4 by Schwinn.
Help appreciated

Upon activity completed the internet connection was lost and activity not uploaded to Zwift and other tools like Garmin and TP. I have just a last fit file, in documents folder.

Is there any chance to upload it additionally?


You can’t upload it to Zwift, but you should be able to at Garmin and TP, Strava, etc…

1 Like

Ok, so it is like one way ticket, during saving. Once failure, no chance. Now I see it was somehow uploaded with missing 20min. So seems partly uploaded. Of course experience points lost :joy:


Cast your vote for

Gang, today’s temporary Garmin Connect not connecting issue should be resolved.

You can manually upload today’s missing session data to Garmin. Instructions to find your FIT file are here.


This topic was automatically closed after 14 days. New replies are no longer allowed.