After Update on 2-19-22 fit file not uploading to Garmin

I downloaded the fit file from Zwift and tried to manually add it to Garmin connect. Failed 2x
Not sure what changed with last update but Garmin doesn’t like it.

if your file does not want to upload to garmin than I suspect there is an issue with the file. I assume your ride did not save properly.

You can use FIT File Tools to change the time and try to load to garmin.

Thanks for the tip, unfortunately this didn’t work.

You may get lucky with one of the other options.

Or you could download the fit file from you pc or Strava.

Hi @Matthew_Baroni

In my own personal experience, Zwift fit files manually uploaded to Garmin’s website have never worked for me.

I can’t explain the reason for this incompatibility because the automatic .fit file upload to Garmin (from Zwift) generally works just fine. I have to assume there’s an issue with Garmin’s website that prevents one from manually uploading the Zwift .fit files specifically.

In the past, I’ve had to utilize a workaround by uploading the .fit file to Strava, then downloading it from Strava (e.g. Export GPX file), and uploading that file to Garmin, which will take it at that point.

Either that, or you can try running the Zwift .fit file through a 3rd-party tool like and see if that’ll generate a .fit file that Garmin will take.

Thanks for getting back to me. I tried the fit repair tool, didn’t work, tried uploading the Strava fit file that uploaded from Zwift, failed. Just rode today and it uploaded ok. That was after disconnecting Garmin from Zwift and Zwift from Garmin, then adding Garmin back to Zwift. Not sure why this happened, possibly because Zwift updated before I rode, perhaps you can send Zwift programmers my ride from 2-19-2022 to see why it is corrupt.
Thank you.

Hi @Matthew_Baroni

You’d mentioned that you tried uploading the Strava .fit file that was uploaded from Zwift, but I’m not sure I understand how you did that. As I’ve done in the past, I’ve gone to the activity in Strava, exported the GPX file, and then uploaded that GPX file to Garmin. Is that what you attempted? If not, please try it and see if it works.

Otherwise, speaking from my personal experience as a long time member of the Zwift support team, I don’t know that we have a point of escalation for troubleshooting a malformed .fit file specifically.

From what I know of it, malformed .fit Files is something that sometimes just happens (but not usually), and when it does happen, the only resource I know of that can potentially correct it is the aforementioned fitfiletools website.

As I understand it, sometimes a .fit file can become malformed beyond repair, and since you’ve already tried the things I’d previously suggested, it would seem that’s the limit of what can be done for this particular issue.

That’s good to hear, however, that your most recent ride auto-uploaded to Garmin without issue.

Thanks for the tip, gpx file uploaded ok. just had to modify a few of the data fields for accuracy and fill in a few that were blank. All good now

1 Like

You’re welcome! It’s great to hear that the GPX file was uploaded ok.