Zwift Play Controller connection issues

Having an issue with the right controller since the update. Not able to cycle its like having a handbrake on. As soon as you turn it off you are released.

Ive noticed in last week or so, when riding along the right Zwift Play controller is not longer paired. It was paired properly and was fully functional in the earlier prt of the ride but when I go to use it again, its not longer working and the blue light is flashing. The software is up to date across everything and its charged. Never happens with left controller.

If only there was some sort of universal standard for connecting a game controller through Bluetooth which could have avoided all of these issues. :unamused:

I have the same problem here, using iOS on Macbook. Even after all updates of software (zwift, companion) and firmware on zwift play.
Did you solved the problem?

1 Like


I contacted Zwift Support and after a long back and forth they sent me a replacement pair. I have not updated the firmware on the new controllers. They seem okay after the first 4 hours or so of riding.

Had my first major issue with my Zwift Play this morning. In the past I have had some issues with drifting but not like today. In a race I steered left and it took me to the left gutter and I stayed there. No response when steering right even though that controller was on. I turned them both off and stayed in the gutter for quite a while getting dropped before going back to non-steering mode. Later in the race turned them on and they worked for a time before doing it again. Left gutter. Dropped again.

Probably won’t use Zwift Play in a race again. Not recommended.

Do you by any chance know if other buttons worked? If the other buttons did not work either, it might be that one of your controllers simply lost connection. That has happened to me before. Turning them off and back on allowed them to reconnect for a time before one of the drops out again before long.

Good catch, the buttons didn’t seem to work. At least I tried to give a Ride On bomb and was unsuccessful. Your experience of turning them off and back on and reconnecting followed by them dropping out again was exactly I had. And I got dropped badly in the race by putzing with it! Grrrr.

I have the same problem running on MacOS… on MacBook Pro. Before the firmware update the zwift play running smoothly but after a latest firmware… i can’t use the right side.

try using it whilst it is plugged in to power.

mine drops out every 30 seconds without power but when plugged in to power works fine.

It also works when paired via the companion app but i prefer to pair everything direct to my laptop as I find this works better for everything else

Been using these for months quite happily but a couple of rides ago the RH one was connecting but not functioning, either steering or the buttons.

Today I can get only one to connect, sometimes the RH side, sometimes the LH but it doesn’t matter because even when connected it doesn’t do anything. It doesn’t steer, it doesn’t brake and the buttons don’t work.

I logged out of Zwift and then it wouldn’t let me back - “Invalid Account” so I went off to shower. An hour later I tried to get onto Zwift and it was updating itself. When it finished, full of hope, I tried again, but the controllers are just as useless.

Tested again using iPhone instead of iPad and both controllers work ok. iPad still useless. I can use the phone but the graphics don’t look so good on the monitor. Have left user feedback.

Similar issue, but using iPhone. I connect Tacx Neo 2T, Garmin heart rate monitor with no issues via Apple TV to Zwift. However, if I use Zwift play controllers, and then have to bridge through companion app on iPhone, it’s hit or miss as to whether it will work. Everything will connect, but then once in a ride, everything will disconnect. Then, when I go back to pairing screen, sometimes only one Zwift play controller will be seen or the heart rate monitor won’t be seen. There’s not a clear time frame in which the disconnection happens. However, going from one activity to joining an event, often triggers it. It seems to be more of an issue with the companion app bridging not doing well with the Bluetooth connections. I have no issues with any other Bluetooth connections. And yes, all devices have most uptodate software version. Both devices are on same network. The Zwift screen on Apple TV and Zwift app stay connected, just not the devices. I like the idea of the Zwift play controllers, but at this point, they are too unreliable to use.

1 Like

Same here, but with Windows 10 Laptop. On another forum someone recommended pairing one conteoller, then the second controller. Another person recommended keeping them plugged in. I do both these things and it seems to not disconnect but rarely now whereas they were disconnecting and reconnecting every minute or two prior.

However, that being said, i think this needs to be fixed and i definitely don’t think it is isolated to Android devices. We need to get to a place where they don’t need to be plugged in and they can be paired at the same time. It appears to be a play controller problem, not a device problem. I have to wonder if the update to allow other stearing to be paired has introduced more problems.

Hello @Doug_Keim5246 and @Nicholas_Sparrow , thank you for reaching out. We’re still investigating this issue at HQ.

Doug, your experience sounds a bit different from the issue that S6 Lite users are experiencing, but I have escalated your account to our engineers and we’ll take a look into those disconnections to confirm whether this is the same issue. If this is an issue with the ZC bridge failing, you would notice all devices disconnecting simultaneously.

Nicholas, after analyzing your recent disconnections, I can confirm that you’re experiencing a different known issue that we’re still working on, detailed in this forum thread. Your Play are disconnecting and reconnecting rapidly, which is happening to some Zwifters pairing over native bluetooth. You should now be able to turn them on together and pair them without leaving them plugged in, but the current workaround for the disconnection is to pair the Play controllers through the Zwift Companion bridge

@Rowdy would you answer this direct question: Do the Zwift Play USB controllers support data transfer? If so, can you guys just release an optional firmware that avoids using Bluetooth/BLE and instead uses USB directly? The bluetooth stuff is clearly not working for a ton of folks. The connectivity irritation has kept me off Zwift for months at this point. I really liked them when they worked and I’m too OCD to “drop it” and just ride on Zwift without 'em.


Hi @Rex_Hardin currently, the Play controllers don’t support data transfer to Zwift over USB, but I have escalated your feedback at HQ. Our engineers are working to improve this issue that seems to be mostly occurring over native Bluetooth. If you’re able to use Zwift Companion as a bluetooth bridge to pair your Play, this has been a very reliable workaround for Zwifters so far.

1 Like

Hi, has there been any progress towards the Zwift play issues? I have had better luck using the account app but it is still not brilliant. In race connections generally seem unreliable, especially when you swap between bike/run. I was about to start the run in the wtrl duathlon, my avatar happily walking on the spot, ready to go and at race off he stopped dead, 0 kph. I keep switching, even log out of Zwift, use aeroplane mode on pc, restart etc and although restarting the computer seems to half the issues, generally find the whole zwifitng experience pretty poor at the moment

I’m having issues with Zwift finding my devices when pairing through the companion app since I got the Zwift Play controllers. I run Zwift on an Apple TV which has been rock solid and have always connected through Apple TV. I recently purchased the Zwift Play controllers and was initially successful in pairing my Neo Tacx2, HRM and Zwift Play controllers through the companion app. Now Zwift won’t find any devices when trying to pair through the companion app. I can kill Zwift and then connect as usual through Apple TV without the Zwift Play controllers. I can then kill Zwift and try again to pair through the companion app, but Zwift does not see any devices. All devices are on the same WiFi network.

Update: I reinstalled Zwift and used the workaround to pair my HRM after joining the event and it is working now. It seems that Zwift was remembering an extra left hand controller, I saw three controllers available to pair. I’ll update if there are any further issues.

Update 2: now Zwift is remembering the devices and the HRM pairs with the other devices through the Companion App, I don’t have to pair it after starting a ride. Not sure what changed to make it work.