Heart rate monitor not connecting [November 2023]

Thanks for your input! :joy: Thought the issue was about HRM not connecting to ATV. I’ve been having this problem for a while and can use the same workaround as mentioned above. Sounds pretty much like the same problem.

Then i got your message wrong. I am sorry pal.

This morning I was able to pair my HRM effortlessly through bluetooth straight to the apple TV. However, when trying to pair through Zwift Compainion App so that I could also use the play controllers, the HRM will not appear or connect. (So for now, I have given up using the play controllers and am just zwifting the old fashioned way, pairing directly to the Apple TV with bluetooth.)

1 Like

Hello all, I wanted to post another update that should help our engineers get a better analysis on this issue if you are still experiencing problems getting your Heart Rate Monitor to pair over ZC bluetooth bridge from the initial pairing screen.

At your convenience, I recommend refreshing your device’s auto-connection settings by:

  • deleting KnownDevices.xml from your Documents/Zwift folder (on PC)
  • deleting and re-installing the Zwift app (on Apple TV). Note: this will require you to enter your login credentials again.

Feel free to let us know in this thread if that changes anything for you.

If that does not change anything, the current workaround method should still allow you to pair via Zwift Companion bridge:

  1. Pair all fitness devices EXCEPT your Heart Rate Monitor at the initial pairing screen, then continue to the home screen
  2. Start your intended activity
  3. Once in-world, select Menu to pause, then select Pair from the pause screen
  4. Pair your HRM from the Pause menu pairing screen

If you’re still having problems after attempting the workaround, please reach out to Support .

Thanks for your help. But, yes, everything does disconnect. Tacx, Garmin heart rate monitor, and Zwift play controllers. Then, when I try to repair things from the connection screen, sometimes only one Zwift play controller will show up and sometimes the heart rate monitor will or won’t. That’s what made me think the issue is the Zwift companion bridge. Using just Apple TV with Tacx and Garmin HRM, but no Zwift play, there’s never a disconnection.

Would like this resolved because the workaround solution through the ZCA causes my HRM not to be picked up (which HR2VP says is a Zwift issue that its broadcast only works over direct Bluetooth connections and not through the ZCA bridge). So for me it’s either steering or heart rate, but currently cannot be both…

Hello all,

We haven’t had many recent reports of this issue, and I can see that a lot of original reporters have been successfully pairing heart rate monitors over ZC bridge lately. Please feel free to update this thread if you are no longer experiencing the issue or are only able to pair via the current workaround method:

  1. Pair all fitness devices except your Heart Rate Monitor at the initial pairing screen, then continue to the home screen
  2. Start your intended activity
  3. Once in-world, select Menu to pause, then select Pair from the pause screen
  4. Pair your HRM from the Pause menu pairing screen

We are still investigating this at ZHQ, but we have not been able to reliably reproduce this issue.

Assume that can’t be a RP ride? So if that’s the plan, start a free ride in same world, pause and pair HRM, teleport to RP?

Issue is still very much in existence for me. Just haven’t seen any updates, so didn’t see any point in reiterating the problem…

1 Like

Hello @Od_Avinu, your situation may be the most unique due to the HR2VP app. Can you confirm what device you’re using as a heart rate monitor?

Yes I’m using HR2VP on a Samsung Watch. It only works by direct BT connection and not through the ZCA. I have tried connecting this first or last (I only have 2 BT devices to connect), on the main screen or subsequently.
I have also tried riding a couple of times without the HRM altogether, as I thought there might be an interference issue. However, I didn’t find the Zwift Play steering experience noticeably different.

Same issue here. Apple TV 4k with everything updated.
Wahoo tickr x, tickr ver 1, and tickr ver 2 won’t connect to Apple TV directly.
Will connect but not display any HR, then repeatedly drops out.
Connecting via Companion App is rock solid.
HR’s connect to other apps fine, definitely an Apple TV issue since 1.52.
Hard restart of Apple TV does not help.

1 Like

I’m having the same problem. I paired my Wahoo HRM to Zwift hub, running Zwift on Windows 10. On the pairing screen, the HRM shows a heart rate, but then early on into the ride the heart rate freezes. Much later on into the ride, it sometimes updates once again, then freezes on the same number for the remainder of the ride. Pairing directly, not through the Zwift hub, doesn’t produce this problem.

I have the same problem here. With my Elite it worked perfectly but now with the Hub it is completely non functional. I can conect everything but my HR from my Fenix 6 rpo (Using iPhone for the compagnion app) and for the Fenix app I try Apple TV or iPad - both shows same results. I tried to connect my fenix with the Hub to get results from there but this works neither. So I don’t know how to use ANT+ for this set up (which seems to work for some of us) but can’t understand why it works for an older device (Eilte) but not for the new one I bought. Zwift told me to release all connections with sensors from my Fenix 6 but that means I can’t track my activities with Garmin, which is my main fitness app…

Update: I had a look into the sensors menu of my Fenix pro and it says, that its connected with “Trainer 60691” and, over ANT+ …

Update 2: I jsut connected all devices (picked Fenix 6 pro in the sensor menu of Zwift App) and it was showing Hr of 50 … constantly! so the broasdcast is not functional

I have had this HRM issue for awhile now. When I delete and reinstall the Zwift app, it works. But when I ride the next day, it doesn’t. Also, the work around option doesn’t work either. However, if I delete the app again and reinstall, it works for that ride only. But stops again when I log in the next day, I don’t want to have to delete and reinstall the app every time I ride. I’m running Zwift on AppleTV and also use the Companion app. Thanks in advance for your help.

Same issue here with Apple TV. HRM will connect, will not display heart rate, then drop the connection and display “Connection failure”.

There is an issue with HR and Apple TV.
Direct connection or Companion app both has issues with HR now.
Either won’t show any reading, or 40 - 50 bpm below what it actually is.
No response from Zwift that I have seen. Chat during robo bot rides shows it is wide spread.

1 Like

It’s been coming up regularly on the Facebook groups. Many of them are apparently related to using Play or Click controllers as well.

1 Like

This issue started for me 2 days ago. HRM displays 0 but works just fine in Wahoo app. Apart from being generally annoyed I’m concerned with ZRL soon approaching

I’m having the same issue.
My Polar dual bluetooth/ANT+ HRM connects with bluetooth directly to Zwift on Apple TV with no issues, but does not connect via Companion App (on Android) - actually it does connect, but reads ‘no signal’. I have tried ‘forgetting’ all bluetooth devices, closing all other apps, turning off bluetooth on all other devices, restarts, etc. with no success.

Similar issue here. I am using the Zwift Hub One as a bridge for HR. I can successfully connect the game to the hub for HR, however, it just reads 0. No issues with my HRM when I use my ipad.