Zwift PC Bluetooth issues

Hello Shooj
I am experiencing the same issues Jonas was having.
I have ran the Lenovo scan and there were no issues reported relating to Bluetooth.
I have tried updating my Bluetooth drive yet I am being told I am using the most up to date version.
I have checked my zwift folder and there is only 1.
Do you have any other suggestions?

Install this: https://www.techpowerup.com/download/visual-c-redistributable-runtime-package-all-in-one/

Reboot your PC afterwards and try again.

4 Likes

Thanks Dave. Seems to have worked a treat

1 Like

Much thanks for the reference to the fix. I built a system from scratch with a Plugable USB bluetooth 4.0 adapter running a 2004 updated version of Windows 10 pro. No problem getting Windows to see the bluetooth Coospo heart rate monitor or Wahoo Kickr Core however Zwift didn’t recognize the bluetooth adapter. Installing all the Visual C runtimes fixed Zwift. A not at all obvious solution. Zwift support should document this or fix their installer to include the appropriate runtimes.

This did the trick for me! Many thanks!

For reference I was using a bluetooth 4.0 dongle and after installing the stuff from your link and rebooting zwift picked it up!

This hasn’t solved my Bluetooth issue. Zwift still doesn’t recognise that my Bluetooth is turned on. Windows does.

I found the external usb Bluetooth dongle to be better.

Like the avantree DG40S

Thanks Gerrie. I bought that, installed it, connected pc directly to trainer… It worked. Connected headphones, it worked. Loaded up zwift… Zwift thinks Bluetooth is turned off - this is definitely an issue with Zwift and it’s interaction with various Bluetooth drivers.

No point in racing, group rides or workouts - ant+ cuts out all the time. I’m going to stop zwift until I see this Bluetooth issue resolved… which seems to have been around for quite a few months so I won’t hold my breath, like with the many other issues for the everyday subscriber… we’re just a vocal group.

You need to install the C++ redistributable packages, see link above.

1 Like

Hi Dave, I’ve already done all of that. Don’t know what’s wrong.

1 Like

What else is in your environment that could be interfering with the signals? Do you have a fan right next to the dongle or something? Move stuff around and see if you can isolate the issue.

1 Like

The ant+ dongle is right next to the trainer. Fans are over 2m away, internet is via. Ethernet, any other signal source is over 4/5m away.

Never had the same problems when connecting via. Bluetooth on my older laptop.

Oh. :frowning:

Interference is another matter, but installing those normally deals with the problem of Zwift not seeing that you have Bluetooth at all.

Imagine straight lines on the ground between all of the WiFi devices near to where you train, and where each of those devices gets its signal from (access point, mesh node etc). Do any of those lines intersect your ANT+ dongle? It doesn’t matter if they’re in use or not, or whether they’re related to your training setup or not. If anything intersects or is close, move that device (or its source of signal) and see if there’s any improvement. Try to ensure clear separation.

Hi Dave, appreciate the advice, the dongle is literally next to the trainer. There is only one WiFi hotspot in the garage and 2.4ghz frequency is switched off on it. The only possible interference can be coming from the house which is a few metres away

Frequency doesn’t necessarily matter. What I mean by straight lines is that if for example the hotspot is directly behind your bike, so your phone using Companion app is passing ‘through’ the location of your dongle, it may well interfere with the signal. I got noticeable ANT+ interference even with my dongle 20cm from the trainer due to this arrangement. You want to ensure clear separation of those lines, so say by moving the hotspot across so it’s not directly behind your bike.

Hi Dave,

Hot spot is about 2.5m away, about 1 o’clock from the trainer. Dongle is literally right next to the trainer… 5cm, 7 o’clock from the trainer.

Bluetooth worked from 2.5m with no problems.

I need Bluetooth back!!!

What I’m trying to say is that proximity doesn’t always matter. It can literally be the lines of wireless transmission that interfere. I see you’ve edited though, seems to be saying that the hotspot is forward of the bike. :+1: So it can’t be the particular problem I’m on about. :confused:

1 Like

I have similar issues. Previously I was using Zwift on iPad and Bluetooth-related things worked (if I remember correctly) without issues.

Now I’m using Zwift on a desktop PC. I’ve done a few rides. The connectivity works once I get Zwift connected. Another change is that I now have PowerTap pedals (which I didn’t have with iPad).

It seems that things work like this when I fire up Zwift:

  1. If the the power meter pedals are “on” AND if Zwift picks them as the “Power Source”, Zwift will never connect to Kick Snap as “Controllable”. The list in “Search” in “Controllable” is empty. I think this is a bug somewhere.
  2. If Zwift picks up Snap as “Power Source”, in a few seconds it will pick up Snap also as “Controllable”.

The 1) happens, I can “Unpair” “Power Source” and from “Search” select Snap. Then (if things work) in a few seconds Snap is selected as “Controllable”.

The “fix” for the whole thing is to start Zwift and turn the cranks using hands to not activate the power meters. Zwift will pick up Snap as “Controllable” and as “Power source”. Then I mount the bike, start pedalling, unpair “Power Source” and Search and connect to the pedals. Wow.

Isn’t their a way to “star” a power source so that Zwift picks that up in the presence of multiple options?

Today I didn’t manage to connect my PC using BT at all. I tried for 5 to 10 minutes, restarting the app etc. No luck, I never managed to connect to all sensors simultaneously. Eventually, I reverted to iPad. iPad immediately connected to PowerTap (left), Snap (controllable), Tickr X (heartbeat) and Wahoo cadence. And while the game was running, no hickups.