Zwift on Windows 10 Dell XPS Laptop - Doesn't start

Apologies if this has been covered before but I couldn’t find it. I tried contacting Zwift Support directly but have had no response so am posting here.

I’m wanting to run Zwift on my Windows 10 Dell XPS 13 laptop. I have installed it and it appears to want to run but then exits straight back out again. I have un-installed and re-installed but with no success… same problem.

Anybody have a troubleshooting guide for Windows 10, or know what my problem could be and can help me get it up and running? I’ve paid for the subscription so I want to be able to use it!


I have got it working. Yay! Things I did:

  • Uninstalled Zwift
  • Checked Windows Update, there was a pending update there for .NET, and also one to update to v1909. I installed that, and re-started laptop
  • Re-downloaded & re-installed Zwift, it went through it’s Update process which took just over an hour

Software runs and picks up all my sensors. Excellent.

Great that it now works!

Looking to get an xps 13 as well, wondering how does Zwift graphics run on it?


Runs just fine although I do dock it to an external monitor which is actually only 1080P, but it’s bigger than the laptop so I prefer watching the larger screen.


So mine has mysteriously stopped working again. I repeated the steps from last time… I checked Windows Update, there was an update waiting so I installed that. Uninstalled Zwift and re-installed it.

Launches and attempts to start but then quits out again… doesn’t even get to the Update screen.

This is so fustrating!!

I’m assuming you have installed net 3.5 as mentioned here (or was your windows update for net different?)

Any chance you elaborate on that? What’s on the screen?

Also, you might want to examine Window’s event log… see here.

To elaborate… there isnt much!

I run the App, it appears briefly on the Taskbar and the System Menu, but then disappears again. There is no Zwift Startup screen or anything.

I have the Event viewer log, but I can’t attach it here. I’ll send it to the Zwift Support reply that I got.

I tried clearing my IE cache but I actually don’t have IE installed, only Edge. I thought there should be a version of IE installed but it appears not.

AFAIK, all Win10 versions have net 3.5 (or later) preinstalled.

See Microsoft’s info, here and Wikipedia.

… but it never hurts to have the latest version installed.

Going through the Windows support pages, it says Windows 10 Version 1909 is the most up to date version, and that’s what I have, I remember at the beginning of this month when I had my previous issues, the .NET update hadn’t been installed, so it was done then, and that fixed the problem then.

So I don’t know what is causing the problem now.

Also, I was remiss in searching for Internet Explorer previously. I had followed Zwift Support’s initial troubleshooting to clear IE’s browser cache. but that hasn’t resolved it.


Uninstall / reinstall may not remove everything related to Zwift. Manual deletion of files may be in order before you reinstall.

Try the steps outlined here, please.

Thanks, and yes I completed those manual deletion of files when I went through the fresh install, as I saw it noted elsewhere.

I backed up the /zwift installation folder so I will send the logs files to the zwift support team.

For the record - Windows 10 does NOT come installed with the .NET 3.5 Framework.

Please manually install .NET 3.5 as we discuss on this previous thread.

1 Like

I checked the .NET installation last night and tried installing it, but the installer said the latest version 4.8 was already installed. I checked and it was installed manually in my last round of Windows updates at the beginning of April.

Also, there is no /logs folder. I guess the program isn’t starting up to get to such a point to actually create the folder or files. So nothing further that I can send to the Support team.

Thanks for your replies though… any further thoughts?

I’m not sure if we’re on the same page…NET 4.8 Framework is a different programming environment. The latest version doesn’t have the stuff that you need to install and run Zwift.

You must also have .NET 3.5 installed in addition, and you haven’t said explicitly that you do. Please verify? Instructions are here.

Different .NET frameworks can be installed on the same machine at the same time with no problem.

1 Like

According to those instructions, I checked the Windows Features and .NET 3.5 is fully enabled, so yes it is already installed. Just to be sure I downloaded the SP1 and tried to install it but it didn’t do anything, so I can only assume that it is installed correctly.

Thing is, it was working up until a couple of days ago. I see there was a windows update done, so I’m going to uninstall that update and see if that’s any better

I found where the /logs folder is… in /Documents/Zwift… I was only looking in the /Program Files x86/Zwift folder. So i have zipped up the /logs folder and sent it to Support.

This is really getting on my nerve now.

@shooj Is there anybody from Support on these forums that can help me? I have tried to contact Support directly a number of times but I haven’t had a reply.

I’ve had my latest monthly charge debited and I can’t use the software, so I’m currently paying for nothing.

This issue is still un-resolved, and it’s pissing me off now.