Zwift on Windows 10 Dell XPS Laptop - Doesn't start

@Paul_Voorend please check your email.

@shooj Cheers mate, I have responded. Still no luck, have followed almost all your and the other support person’s suggestions. Have attached logs again for further review.

Thanks, Paul

Format your HDD/SDD, install Win10 fresh without the Dell bloatware, install .NET 3.5 Framework, install Zwift.

That is most definitely last resort and not something that I take lightly. I use my laptop for work and I have numerous applications that would also need installing and configuring if I was to blow it all away. Just for “trying” to get zwift to work… It’s not worth it.

So this is a work computer? Is it managed by your IT department?

No it’s my own personal laptop

Pick up a cheap 120GB SSD, install Win10 there and test if Zwift works.

If yes, get a USB3.0 HDD case. When you want to zwift, boot from there, otherwise boot from the internal device.

Do you mean like an external SSD? Would I need a new Windows license to do that?

No, your PC already has a Win License. It is stored in the UEFI.

Yeah, you could use a external SSD too.
If your Notebook has a M.2 or mSATA SSD as main device and an additional 2.5" bay for HDD/SSD, you could use that.

Well the laptop is a Dell XPS 13 2n1. I don’t know, or rather I don’t think, there would be room for a spare drive. I’m guessing I’d have to take it apart / unscrew the back somehow to confirm whether this is the case or not… unless Google can tell me

EDIT: The SSD is Toshiba 512GB M.2 NVMe SSD, Dell P/N: 07VPP2, user-replaceable but only the one drive, so can’t install a second one.

So to try the above suggestion, I think I’d prefer the external option. Could I do it by using a MicroSD card inserted into USB-C or Thunderbolt?

In theory yes, but a microSD card is really slow, even if it’s a Class10.
But if you have one laying around you could try.

Well I’m willing to try anything really. So the next thing I need to find out is actually how to install a fresh copy of windows onto said Micro SD. The laptop has a built-in MicroSD card slot and I’ve found the option inside the BIOS to enable the MicroSD card as a boot device, which it isn’t enabled at the moment.

For a further troubleshoot, I have also been trying to get the laptop to boot into Safe mode but I haven’t been able to get that yet. No option inside the BIOS, F8 key doesn’t work, and an option to enable the F8 key, also didn’t work.

I appreciate your help though

Safe mode:
Restart Win10 while holding the Shift Key.
You get into a menu, where you have different options in troubleshooting.
Press start options.
The machine will restart.
Then you can tell Win to start in safe mode.

To install Win, download the Media Creation Tool from Microsoft. With that you can build a bootable USB Stick with Win10.
Start your PC from that Stick, and you can install a fresh Win10 on the MicroSD.

Well that’s a new boot / reboot procedure… not seen that one before… but it worked.

And this is interesting progress… I booted into Safe mode with networking… tried running Zwift Launcher and got a message saying no internet connection. Ok… so “with networking” doesn’t include Wifi. Gotchya.

Connected via my hub and ethernet… tried again. It worked! Was doing an updating screen but then stopped responding, so I ended the process and tried again. It allowed me to log in. But then I get a message:

“Zwift requires OpenGL 3.1 or higher to run. Don’t worry though, your computer probably supports it, you may just need to update your graphics drivers. If you need help with this, contact

Which that messaging is fair enough seeing as I’m in Safe Mode. Will re-boot back into normal mode and see if there’s any progress.

EDIT: Nope… back in Normal mode… same behaviour as before.

Win10 in safe mode doesn’t start most drivers. That’s why it’s called safe mode.
Of course the graphics driver is then the Microsoft Basic driver.

What graphics card do you have?

Maybe it’s better to look for a new/used gaming notebook for zwift?

1 Like

Intel HD Graphics 615

Found another diagnostic tool - OpenGL Extensions Viewer. Ran that and it said the Intel Graphics driver was 11th April 2020. So I immediately knew something was amiss.

Intel website said most recent graphics drivers were May 2020. I already knew this from the other day when I downloaded and installed them, so why it’s reverted back to 11th April… don’t know. Maybe something to do with the Safe Mode?

Anyway, requested Windows Device manager to check for updated Graphics drivers. It “updated” the driver… to 25/09/2019.


So I have re-downloaded the Intel Driver & Support Assistant… again, to go through the Display Driver update… again. It did detect the old drivers so just following the same upgrade path again as last night.

I’m not holding my breath… but maybe?

Intel DSA has updated the drivers successfully to the latest version:

OpenGL Extension Viewer reports back the same version number, and the date of the driver is 17th April 2020.

Windows Device Manager also gives the same info. I think this is the first time where I’ve had matching info from more than one place at once.

Uninstalled Zwift… again.

Removed all the Zwift folders from /Program Files x86 & /Documents. There was nothing in Downloads but deleted all previous installer files. Emptied Recycle Bin.

It’s now that I realise I possibly shouldn’t have done that, as now it will have lost any software settings from when it tried to work in Safe Mode. Hrmmm.

Re-downloaded and installed Zwift… again.

No joy. Grrrrrr

Restarted again in Safe Mode. This time running the Zwift Launcher, the Update process completed successfully. Good. Same OpenGL error when trying to run in Safe Mode. Ok, expected that.

Restarted Windows back to Normal Mode. Checked both of the Zwift installed directories, many of the files had the most recent date & time from the update. Good.

Ran Zwift Launcher. Still no luck. Running ZwiftApp.exe now doesn’t even bring up the incorrect version error message that it used to. That’s different… I guess since the update process worked, that’s no longer an issue.

So I’m almost ready to give up on running it from the laptop, and use my Samsung phone, cast to Google Chromecast, which I got working the other night. Such a fan-dangled way around it, but it worked. Then use an older Samsung phone as the companion.

But I really want to get it to work.

@shooj do you want me to send through any more info through to your Support email? I haven’t gone through those other steps regarding that error code… I didn’t think it related to Windows 10, more of a Windows 7 / older problem?


Our team has already read through your log files in two passes. It appears something’s gone sideways on your specific laptop. Gonna be brutally honest and say that troubleshooting Windows issues this deeply goes beyond the scope of Zwift tech support’s responsibility.

Do you have another device that can run Zwift? We run on iOS, Android, Apple TV, and MacOS too.


Yeah I can use my Samsung phones, one as the cast device to my PC screen, and the other as the companion. It’s just a really convoluted way of getting it done, but it does work.

@Paul_Voorend, what resolution do you have set on your laptop in display settings, also what is the scaling set at, for example 100% or 125%?

The reason I ask is my Dell laptop will not run Zwift on 100% scaling and I have to bump it up to 125%