Zwift Doesn't Launch (Windows 10)

I just downloaded Zwift for the first time. Install went fine, but when I click on the icon it doesn’t launch. Same thing when I try from the start menu. I don’t see anything open on the task manager. System is well above the recommended specs as far as I can tell: AMD Ryzen 5 2600X, 32GB RAM, MSI GeForce RTX 2060 6 GB VENTUS OC Video Card, 1TB SSD with 747 GB free. Drivers are all up to date.

Are you in Germany and using Telekom as ISP?
If not, how is your Internet connection?

No, I’m in the US. Per speedtest.net, I’m getting 94.78 down, 94.86 up

Try to restart your PC and open Zwift as administrator.

Tried it. This time I got the security warning saying asking to allow ZwiftLauncher, but when I allowed it, still nothing happened.

I’m able to load it on my laptop using the same internet connection, but would really like it to run on my desktop as the GPU is better.

Zwift launcher uses internet explorer to run, do you have that disabled or a fire wall preventing it from working?

2 Likes

I don’t think so— explorer is installed and updated, and it runs just fine. I usually use Chrome, though.

1 Like

Tried updating windows, reinstalling Internet Explorer, rebooting, checking firewalls-- still no go. When I click on the icon to open the Zwift Launcher, a process opens for about half a second called Microsoft .NET Error Reporting and then disappears, but I can’t seem to find a log of the error anywhere.

You need to make sure that .NET 3.5 is installed.

2 Likes

Hi, Paul,

Thanks for the suggestion. I checked my registry and it looks like it is. Any other ideas?

Why would you check the registry for it?

Open Control Panel
Programs and Features
On the left-hand side click Turn Windows features on or off
Make sure .NET Framework 3.5 (includes .NET 2.0 and 3.0) is checked.

Hi, Paul,
Sorry, I had found a website telling me to check the registry to see what version I have. Just followed your steps here, and yep, “.NET Framework 3.5 (includes .NET 2.0 and 3.0)” is checked. So is “.NET Framework 4.8 Advanced Services”, if that makes a difference.

1 Like

Ok, let’s start over.

What happens when you click on the Zwift icon?
What is the version number installed?
I am assuming it is a x64 Win10 PC, but can you verify that.

1 Like

When I click the Zwift icon, the cursor changes for about a half second to the “processing” blue circle, and then reverts to an arrow. Concurrently, a process opens for about half a second called Microsoft .NET Error Reporting in my Task Manager and then disappears.

My Windows version in 10.0.18363 and it is x64, yes. I assume the Zwift version is the most recent one, since I just downloaded it again.

Uninstall Zwift and delete ALL the files in \documents\zwift

Restart your computer

Download and reinstall Zwift.

I can’t find a \documents\zwift folder anywhere, but I tried the rest with the same result. Should the folder already be there if I haven’t ever been able to launch the app yet?

It should be located here: C:\Users*your user name*\Documents\Zwift

Yep, that’s where I looked. I’m able to find it there on my laptop, which was able to run the program, but not on my desktop.

Do you have an antivirus program on it?

Symantec