Zwift does not open after the installation

Hey fellow Zwifters.

I currently run Zwift on my Laptop which works just fine.
But now i’d like to run it on my main desktop pc, since it has more power.
But after installing it, there is no window opening.
Meaning for some reason it does not start at all, when clicking on the icon.

All my drivers should be up to date aswell as windows.

I have got a i9 9900k with 16gb of ram and a Gtx 2080.

Hopefully you are able to somehow help me, fixing my issue.

Open Control Panel>Programs and Features
On the Left-hand side click on Turn Windows features on or off
Make sure .NET Framework 3.5 (includes .NET 2.0 and 3.0) is checked.

What anti-virus program are you running on the desktop?


Thanks for the reply. .NET Framework 3.5 is checked.
And there is no anti-virus programm running right now.
Still doesnt change anything.

try running it as administrator?


Yes tried that aswell.
Didnt make a change. Sadly.

What folders/files do you see in \Documents\Zwift


Is there any kind of VPN or Proxy installed on the desktop?

You could try resetting your Internet Explore/Edge browser to see if that helps.

1 Like

Not having any kind of VPN right now.
I did reset Edge and downloaded/installed again.
Did not change anything again.
Its just really weird that Zwift appears in my Task Manager for a split second and
is gone again in a blink of the eye.

what resolution settings do you have, screen size, etc…

I’ve had issues with this on my laptop when running zwift in 1980 x 1080 resolution, but at 100% scale it will not run, I have to change it to 125%.

Well running multiple screen. 1 21,5 inch 1080p, 1 27 inch 1080p and 1 TV connected to my pc.
Tried using zwift only by having one monitor plugged in didnt change anything.
You changed the scaling inside the nvidia control panel settings or through windows.
Obviously cant change it inside zwift.

yes in windows display settings. Right click on the desktop. I think you should try with only one screen first, or are you extending the multiple screens or duplicating them? Maybe this is the issue.

1 Like

Also try this:

Documents/Zwift/prefs.xml file and changed the FULLSCREEN field from “1” to “0” according to the following:


To see if that helps.

1 Like

For some reason i cant open the mentioned file.

OK, try uninstalling Zwift and deleting all the folders in \documents\zwift
Restart your computer
Re download Zwift
Reinstall Zwift
Open Zwift


That was it!
Thank you for a patience and your tips.
Really appreciated.


Glad we could help.

See you on the roads!

Ride On!