Zwift will not launch on windows 10

Have a pretty expensive gaming rig w/ windows 10. Latest drivers and such. Game will not launch at all. Shows up as process/program in task manager, and then closes after half a second.

If you look in C:\Users\<username>\Documents\Zwift\Logs you should find Launcher_log.txt.

If you open that in Notepad it might offer some clues.

(Or Log.txt if you mean the main game.)

1 Like

Thanks. This is all it has:

[17:07:47 2020-03-08] Launcher: Checking for VerCur Override
[17:07:47 2020-03-08] Launcher: prefs.xml file found.

Hey Troy!

I found the chat you had started earlier with Zwift Support, and I sent you an email to help troubleshoot this!

1 Like

So, this also runs just fine on my macbook over wifi. Responded to support email with logs and computer specs. Have not heard back. I need this to work on my windows 10 pc, as advertised.

Please advise.

What is your computer specs?

Did you try to do a clean install of Zwift after deleting all Zwift files.

1 Like

16gb ram, i7 processor, ssd drives, and 1070 nvidia. Attached specs for more details. Thank you for reply.


System Information

  Time of this report: 3/9/2020, 12:19:22
         Machine name: DESKTOP-QE5G72N
           Machine Id: {9BDCE016-209A-451E-820E-526F9C0BE317}
     Operating System: Windows 10 Home 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
             Language: English (Regional Setting: English)
  System Manufacturer: System manufacturer
         System Model: System Product Name
                 BIOS: 0616 (type: UEFI)
            Processor: Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz (12 CPUs), ~3.2GHz
               Memory: 16384MB RAM
  Available OS Memory: 16308MB RAM
            Page File: 11617MB used, 13394MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 96 DPI (100 percent)
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode


DxDiag Notes

  Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Sound Tab 2: No problems found.
    Sound Tab 3: No problems found.
    Sound Tab 4: No problems found.
      Input Tab: No problems found.

DirectX Debug Levels

Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)


Display Devices

       Card name: NVIDIA GeForce GTX 1070
    Manufacturer: NVIDIA
       Chip type: GeForce GTX 1070
        DAC type: Integrated RAMDAC

Make sure that you have .Net 3.5 installed on it.

1 Like

Hi Troy!

Welcome to the Zwift Community Forums!

Have you checked for windows updates? Build 18362.19h1, also known as Windows 10 version 1903, contains a known bug that messes with Bluetooth Low Energy (BLE) for various devices, but not all. I heard mice and keyboards will work fine, but trainers, headphones and other things were all effected.

Try updating to 1909 or later, and see if you can pair after that.

I don’t have an issue with devices pairing, the Zwift application will not launch.


Seth
Seth_Steen
Zwift Support Agent

    March 12

alt Troy_Talbot:
10.0, Build 18362

Hi Troy!

Welcome to the Zwift Community Forums!

Have you checked for windows updates? Build 18362.19h1, also known as Windows 10 version 1903, contains a known bug that messes with Bluetooth Low Energy (BLE) for various devices, but not all. I heard mice and keyboards will work fine, but trainers, headphones and other things were all effected.

Try updating to 1909 or later, and see if you can pair after that.

Updated to latest build, and all windows updates are installed, including those for .net 3.5. Zwift still will not launch.

Well, I’m clearly handling too many conversations at one time, sorry for the bad advice. Launcher issues are typically internet related, rather then spec related. More so since your specs make me envious. Zwift uses the system browser for the launcher, regardless of what you personally set as default, so make sure to update Internet Explorer, and clear its cache to see if that helps.

VPN’s are pretty popular now days, and if you happen to use one, that can also prevent the launcher from working correctly. If these basic steps aren’t helping, reach out to our Support Team at Support@zwift.com and we can take a much more in depth look into the issue. Feel free to attach your logs from documents/zwift/logs if you would like, as those may also tell us what’s happening.

2 Likes

So I was also having huge issues getting this to work, read through the logs and i noticed that the following .dll file wasn’t working on my computer: bink2w64.dll

I did a System Checker (Command Prompt Run as Administrator check) and this fixed my system files. I restarted my computer and it worked.

Method 3: Fix Bink2w64.dll missing error with System File Checker (SFC)

I also checked my Anti-virus to update allow internet settings (made it as open as it could be) which also kicked it into gear!