Zwift "Logs" Folder Incompatible with OneDrive Sync

For some strange reason, Zwift stores its logs (and also a “TEMP” folder) in the Documents folder instead of the proper place on a Windows machine, which I believe is %appdata%. I, like millions of other people, keep my files synced with Microsoft OneDrive. Unfortunately OneDrive and Zwift fight with each other because Zwift is constantly writing to the logs (at least on startup) while at the same time OneDrive is trying to sync the file changes. This results in Zwift hanging on launch due to files being “in use” by OneDrive.

A “solution” was posted some time back (Move "working files" i.e. logs to Program Files (OneDrive issue)), which does not fix the issue. The suggested fix is to go into Settings > Account > Choose Folders and un-check the Logs folder. OneDrive warns you that un-checking a folder makes it unavailable on this PC, meaning the folder gets deleted (though the cloud copy remains). If you recreate the folder, OneDrive complains that there is now a sync issue because the same folder exists in the cloud. Deleting the cloud folder allows it to sync the Logs folder again, bringing you right back where you started.

Will Zwift fix their Windows app so that it stores logs and working temp files where they belong? That is the only real way to fix this issue.

Hi Steve!

Welcome back to the forums, I see it’s been a while since your last post!

Zwift recommends not syncing any of the Zwift file folder, as it can cause complications with how Zwift reads and writes data, and a common troubleshooting step the provide via their support team is making sure Documents>Zwift is excluded from ANY sync programs, be it OneDrive, DropBox or anything else.

1 Like

Hi Seth,

I’m not sure if you read through my post, but this isn’t possible with OneDrive (not sure about OneDrive for Business). If you un-check the folders from syncing, it deletes them locally. If they are recreated you will get a sync error because they still exist in the cloud. If you delete the could copies (or rename them) OneDrive syncs them again… putting you back to the original issue.

You might say that OneDrive really shouldn’t work this way, but I prefer knowing that all my Documents files are securely backed up in the cloud. If I don’t want something backed up, I shouldn’t put it in the Documents folder. The overall point is that folder is for personal documents; it was never intended as an area for programs to write files in which they depend in order to function. Every other program I’ve had doesn’t put its working files there.

Can you please bubble this up to development? The proper place is %appdata% I believe. Every other program has a folder there for its working files.

Thanks,
Steve

3 Likes

This issue is causing havok with my onedrive synching as well. Has there been a resolution to this?

Regards,
Rich

I don’t have a solution, but I do share your frustrations.

I had a number of programs (mainly games) I used to use that by default put important files in the Documents folder, which really annoyed me a) because that’s the folder for MY documents, not your program’s files; and b) as you’ve found it also broke things like syncing to OneDrive if the files were open.

The only way round it I found was to create a separate folder called “My Documents” and put THIS in the default Documents folder. Then change all my shortcuts to point to this sub-folder and make it so that this was the folder synced with OneDrive etc. That way I had a folder that I was in control of that no other program would start randomly saving its log files to without my permission.

This was long before I started using Zwift of course, so when I did install that, I never noticed that it also put its files in the Documents folder until you mentioned it, because I don’t go into that folder any more (and checking now, it is full of rubbish from LOTS of different programs - don’t know why, as Windows provides plenty of places like AppData and SavedGames for them to use instead…)

My solution isn’t great as it forces you to do the work of moving your files instead of program makers doing it correctly in the first place, but it’s a workaround I suppose.

2 Likes

I have exactly the same problem with Zwift and OneDrive. Very frustrating and as you say, easily resolved if Zwift saved the logs elsewhere.

The only solution I have found is to stop Zwift running from startup.

Agreed - I don’t have Zwift run at startup and I have to remember to pause OneDrive syncing before I start Zwift, and resume it afterward. :roll_eyes:

how do you stop Zwift from running at startup?

Just right-click the Zwift icon in the task tray and uncheck Auto Startup. :+1:

image

Thanks for the quick response! Definitely helped! I have Windows 10 (new lalptop) - so it was slightly different. I’m adding here for others: I had to right click the desktop icon, and then click “Unpin from Start”. That helps “most-of-day” OneDrive operation, where I am not Zwifting - so OneDrive can run without error. Just prior to executing Zoom, I then “pause” OneDrive syncing as you suggested. That works too. The only problem remaining is that when I’m done Zwifting and I “resume” OneDrive syncing - OneDrive immediately throws an error, over the same Log file issue! Somehow Zwift must stay alive after you quit… To solve this I must reboot the computer to clear out Zwift from computer memory. Very annoying! If you or anyone have a suggestion on how to avoid having to restart my computer after every Zwift session, that would be very welcome!

Dealing with this issue now - just bought a new Windows 10 laptop - and I have to agree with Steve. With the latest version of OneDrive, it is now “all or nothing” on syncing the Documents folder. OneDrive does allow you to not sync the ENTIRE folder, but they do not allow selecting individual sub-folders to not sync. Since there are many legitimate sub-folders and files in Documents that I need to have synced with OneDrive, your proposed solution will not work. I used Steve’s suggestion above (unpinning Zwift from start menu, and then pausing OneDrive every time I Zwift)

Hi Leslie,

Good point; once you use Zwift and then close out, it keeps itself running in the background (I think maybe to keep itself updated). So, after exiting Zwift, right-click the little Zwift icon in your task tray (you probably first have to click the little up arrow to display all the task tray icons) and click Exit. Now Zwift if completely gone and won’t interfere with OneDrive syncing. If you forget and accidentally resume OneDrive syncing before completely exiting Zwift, OneDrive will still complain but it’s okay, just give it a minute or so and it’ll realize the files aren’t being held by Zwift anymore and go on it’s merry way.

image

One more little tip: if you don’t want to have to always click the up arrow to see the Zwift icon, you can drag it down into the task tray (maybe next to your OneDrive icon) and it’ll stay there. That way you will always be able to see it and know when it’s still running.

Hope that helps! It’s absolutely ridiculous that we even have to do these workarounds. Zwift truly needs to design their app for the operating system it’s running on; no other Windows programs that I have store their working files in Documents. I think that went out with like Windows 98! :roll_eyes:

3 Likes

Just adding my feedback - this is not a solution to the problem, as OneDrive does not allow you to exclude the Zwift folder within my documents.

Please move this logs folder or create a way we can move it.

2 Likes

I know this is an old thread, but having the same issues. Pretty annoying that you have to disable syncing and jump through hoops to get this to work correctly. As Steve mentions, the documents folder is not the place for a program to write files to. It would be good if this can be looked into.

1 Like