Zwift not creating any fit file

Hi All

I got a Problem that i really getting on my nerves. After a ride nothing is saved in the “C:\Users\santi\Documents\Zwift\Activities” Folder.

Yes i got enough Space and i’m Admin on my complete machine. Yes i got One Drive and another Cloud Synchronization Tool but it worked until 2020.08.29 and i made no change whatsoever since then. I got plenty of free Space.

Also i monitored my Network Connection and there are no Outages on my Network Connection. The 31.08.2020 i made the Latest Windows updates.

My System: Windows 10 Version 19.09 Build 18363.1016

Can someone with the same Version and Build confirm that anything is working over there?

I tried to turn off all security settings in Windows like Real time Scan and stuff like that. I checked the Event viewer for any Error but nothing to find there.

So i am thankful for any advice that might could help.

I would disable these from your documents folder.

1 Like

Hi

Well i don^t have them on the Documents Drive. All my Cloud Folders that are synchronized are on a Separate Drive that is completely autonomous from the “C:” Drive where the activities should be stored.

Also that would be pretty strange since i use it like that since almost 2.5 Years without any kind of Problem. I never change the Configuration except for Windows updates.

Do you have a log file in the C:\Users\santi\Documents\Zwift\logs folder for the ride you mention? And have you opened it to search for any clues (it frequently writes/updates a FIT file so I woudl expect some type of error … but could also be wild goose chase).

in fact i did that as well and yes i got some files in there one is called “Launcher Log” from yesterday but there is nothing there that would make sense for me. I got a few errors but anything worked fine while riding so i’m not sure if they have an impact.

You should also have a log.txt file with a date/timestamp matching the ending date/time of the ride in the same folder as launcher.txt

What you should have is something like this:

And thats where I would expect to see an error if it wasn’t writing a file.

hey again

well i my “Log” Folder the only file that was created Yesterday is that “Launcher_log.txt”. I can not really see anything that would make sense to me or something marked as Error.

In fact i checked again and i gt a Line like that.

11-09-_2020_10-54-10|690x120

OK, weirdness. You appear to have some files written to the destination folders but not others.

Commenting on Gerrie’s suggestion - I found that OneDrive forced itself to start replicating my Documents and I have never used OneDrive - so just because things have been the same for 2.5 years, you may find they arent the same.

Also, you suggest nothing changed on your PC yet you had a Windows update 2 days after you said it worked. Zwift didnt change anything until 3rd Sept.

Next question if you dont mind - why do you actually care about your FIT files? What problem are you actually trying to address? Are rides not being recorded by Zwift?

hey

no i don’t mind at all.

Well windows updates are changes your right but since I’m a system engineer myself I got a dummy System Clone and i make all the Updates there before putting them on my productive machine.

Well no fit file no ride/data. I could use one of my Garmins to track my Indoor Rides but why use another device if Zift can and did that for me all the TIme.

I just checked and your right. That damn OneDrive has Documents on the Sync even i excluded anything except for my D Drive that is my Cloud Drive.

I check that out as soon i can get on my Kickr. Thanks men for your help

2 Likes

Check that it isn’t your anti virus software which prevents zwiftapp.exe from writing to Documents\Zwift

i have and never had antivirus except for defender

Defender can also cause problems like this.

well yes but i have all important folders on exceptions rules in defender. also I have a software that we use at work and where i got testing licenses. the software monitors folders, processes services etc etc.

long story short it never writes anything to the folder. there are no changes whatsoever except for that launcher log file. there are no services or programs that try to access that folder because that would have been monitored.