Zwift keeps crashing while saving

Today I wanted to try Zwift with my new Kickr Core. Everything seems to work but Zwift keeps crashing while saving. I cannot use it like that. I already found the old thread and it says that the problem should be solved a long time ago. I tried three different thinkpads with three different versions of windows (7 SP1, 10 1703, 10 1809). I live in Germany but the language was set to English. I also did not use BT but a ANT+ Receiver which found every Sensor and seems to work fine. I tested it with only the Kickr connected but without succes.
Will there be a fix for this problem in the near future?

Thanks

I’m sorry that you’re having issues with Zwift crashing. If you could submit a support inquiry to us, we could further investigate and help find the root of the problem. As a friendly reminder, make sure that your version of Zwift is up to date.

Thanks!

I sent you a message including a logfile. Today I tried my ipad but the “saved” activity does not show up on my-zwift.com or in the companion. I paired Zwift with strava but there is also no activity. At my.zwift.com I can see the activities but without the name and the wrong distance. The companion even says that my activity is still going ignoring that I saved two different activities in the meantime.

Yesterday I helped a friend installing Zwift for his new Wahoo Kickr + climb. The first ride we could save without problems. We continued setting up other stuff like connecting with Strava and installing the companion app. When we did another ride Zwift crashes when we try to save the ride, and it keeps crashing no matter what we try. I also did a reinstall of Zwift but it keeps crashing. During the ride everything is working fine.

Zwift is running on a Windows 10 laptop with the kickr connected through an ANT+ dongle. Zwift language is English, Windows is in Dutch language.

It sounds like you may be experiencing this issue.

Maybe, but it’s not just the ride not uploading, the game crashes too. Normally when you end a ride you go back to the main menu, but in this case the game just exits. It’s also not sporadically but at every attempt.

How do you end the ride? Try the onscreen menu.

I tried both ending the ride through the on screen menu, and the companion app. Crashes in both cases.

Is there a log I can check to get a hint on why it is crashing? It worked fine on the first ride, I can’t figure out what is triggering the crash.

logs are under documents/zwift/logs. I live in Germany and I tried to ping zwift.com but it was too slow, so no response. I traced the route and the routing issue seems to be in the US. There are a lot of hops and some servers not responding. Maybe you could check this too?

A few minutes ago I tried VPN with a server in Canada with the same issues (no saving, crashing, ping timeout and very bad routing…) So my connection is not the cause for these problems.

The problem is with my friend’s setup, so I can’t test it right now, but from my own internet connection the ping to zwift.com is also a bit high when it reaches the USA, and the last hops do not show any results when doing a traceroute.

I don’t think it’s the internet connection because everything is working fine during the ride. I also see .fit files being created, I haven’t checked yet if they contain valid data, but they did not upload before the crash.

I can`t even ping zwift.com. It takes 7000ms until the timeout without response. Maybe It is blocked?
When did your friend create his account? I created mine on sunday and the issue was there from the beginning. May be you could log in on your friends setup with your account to see if it is a problem with the account or the setup.