Zwift IOS App Failing On Save Loses All Ride Data


(Tim Clauss) #1

Hi, brand new Zwift user.  I’ve only used the IOS app on my iPhone7+  I’ve ridden twice and at the end of my ride, I press the save button where it shows that it will upload to Strava.  When I do this, It jumps to a new screen showing my name with 0 miles ridden and a right arrow like it wants me to press to log back in.

When I do this, it gives me an error saying there is a problem logging in with my account.  The only option I have from there is to Add a User.  If I do this and relog in, the entire ride is lost.

I’ve lost 2.5 hours of riding time so far.  It sucks.  I’ve gotten zero XP recorded or achievements earned during rides. I know the sync works, because I save a couple of tiny little test rides, and they are in my Strava account.

I will try dumping the Strava connection and re-logging in.  Maybe deleting Zwift and re-logging in.  I would really love to hear from support on this one. My app version is 1.0.15471


(Eric Swaidner) #2

I had a similar issue with my first time using the iOS app.  I have not yet found a solution and am seeking help.


(Dalibor Ban) #3

The same problem here. Zwift at IPad Air 2. No Strava upload, ride marked as partial on Zwift account but with zero km.
:frowning:


(Nathan Budd) #4

Just had the same problem. 

:frowning:


(Duncan Andrews) #5

Same issue here. iPad Air 4 running iOS 10. Mine has not even stored the rides as partial. Lost two rides so far.


(Jason K) #6

Hey all, thanks for the reports, and sorry for the issues so far. We found a bug with some iOS rides triggering a false-positive with our simultaneous login prevention and causing this issue.

The good news is that we’ve applied a fix for this on our end, and it should no longer be occurring.

While we can’t upload any lost rides to my.zwift, you should be able to find your .fit file locally if you need to upload it to any third-party services. Details in our KB article.

Note that this is different from if you don’t see any riders or are seeing partial rides.

Thanks for your understanding as we get through these initial launch growing pains. :slight_smile:


(Nathan Budd) #7

Thanks Jason.

IMHO one of the attractions of the iOS app s being able to use Zwift without a computer.

Without a computer, it’s not possible to access the file system of the iPad to get to the .fit file. Obviously the Zwift app itself can access it, so it would be useful if either the app could sync the files with some kind ot 3rd party app (eg Dropbox, OneDrive), or if they could be emailed as an attachment.


(Elena Truelove) #8

Same thing happened to me last week and also today. Does not seem to be resolved yet


(Bill Unger) #9

Not resolved.  Just happened on iPhone 7.  Very frustrating.


(Lars Johansson SZR (B)) #10

Just happened to me, when i was in the lead, i think i was first crossing the finish line. But not saved! Partial ride, wtf?!?

 


(Lars Johansson SZR (B)) #11

it’s ignorant to release a ios version that is not reliable… Money back guarantee?

 


(Craig Seager KISS (D)) #12

Still happening for me -ride not saved at all to either strava or my zwift activities.


(Katie Massen) #13

I have the same problem on my morning ride trying out Zwift.  Loved the ride, but disappointed that not only was my ride lost but I cannot log into zwift on my iphone 6 on version 1.0.15530.


(Chris Gardner (USMES)) #14

I just had the same issue with my ride using my iPad this morning.  

When I started the ride, it looked the same as it does on my computer.  As soon as I started pedaling, all of the other riders disappeared and never returned.  It didn’t bother me this time, so I continued the ride.  After I was done, I clicked the Save/Upload to Strava button, and it immediately went back to the login in screen.  I clicked my profile, and it said that the profile didn’t exist, and that I needed to login.  I logged back in, and the ride data was gone.

Due to family being in town for Xmas, I had to move my trainer to another room and resort to using the iOS version for a few days, but based on my experience this morning, I may just use my ELEMNT to control my KICKR Snap, and go without Zwift. 


(Bill Unger) #15

No formal update from Zwift on this?  

I was excited to use the IOS app as it was extremely convenient, but am not going to use it until the issue is addressed.  <sigh>


(Tim Clauss) #16

It finally worked!! But the bullet and gave it one last chance. Rode for 70 minutes and it saved it! Note, in my previous rides, all the other riders disappeared at some point, but not on this one.


(Greg Steel) #17

I did my first ride this morning…and had the same issue.  Loved the ride, but hate this bug !!

Halfway through all the other riders disappeared.  Clearly at this point is where the failure occurs, so be warned.  My 1Hr + hill ascent only gave me a 20 min partial.  


(Chris Huck WBR B) #18

I had no problems the first time I used Zwift on my iPad. It automatically uploaded my ride but, I had to manually download the workout file to upload it to Strava because I hadn’t yet linked my accounts.

However, yesterday, a few weird things happened. First, I was placed on the London course, even though Watopia was on the schedule for that day, and so there were no other riders around. Then, at the end of my workout, I received a sign-in error when I tried to save my workout to Zwift. It also had Strava greyed-out even though I had linked my accounts.

The only thing that I could imagine causing the problem was that I had downloaded the Zwift Mobile Link app for my iPhone while I was riding and logged in. At first, it was displaying my live stats on the phone as well as the iPad but, then it stopped.

I tried to look at the files stored on my iPad through iTunes but, they were empty and so the ride data was lost.

This sounds a little like the multiple sign-in bug that was mentioned by Zwift in a response above? Just my 2-cents.


(Adam Papai | WoOh) #19

 

Hey Guys,

Today I did my very first “real” ride with a Tacx Neo using an iPad Air 2.

Zwift version: 1.0.15530

After a 45min ride (20k) I hit stopped my ride, hit save. It said that it will upload to strava. Nothing happened, just throwed me back to the login screen.

I later connected my iPad to the mac and checked the activity files. The activity file has the size of 0 byte exactly. 

Here is the related log snippet from the save.

[17:04:05] BLE: TACX queuing grade change to -0.00
[17:04:06] Wheel Rev: 8917 Wheel Time: 30763
[17:04:06] Crank Rev: 4017 Crank Time: 29696
[17:04:06] BLE: TACX queuing grade change to -0.00
[17:04:06] FPS 29, 500231, 10838, -104940
[17:04:07] Crank Rev: 4017 Crank Time: 30720
[17:04:07] BLE: TACX queuing grade change to -0.00
[17:04:08] Mouse click at 939 1016
[17:04:08] ANT : BLE: Tacx set road texture 0 (time=177421174)
[17:04:08] Wheel Rev: 8918 Wheel Time: 32434
[17:04:08] Crank Rev: 4017 Crank Time: 31744
[17:04:08] BLE: TACX queuing grade change to -0.00
[17:04:09] Crank Rev: 4017 Crank Time: 32768
[17:04:09] Mouse click at 228 1487
[17:04:09] BLE: TACX queuing grade change to -0.00
[17:04:09] FPS 28, 497557, 10827, -105064
[17:04:10] Wheel Rev: 8919 Wheel Time: 34813
[17:04:10] Crank Rev: 4017 Crank Time: 33792
[17:04:10] Mouse click at 1349 1265
[17:04:10] BLE: TACX queuing grade change to -0.00
[17:04:11] Crank Rev: 4017 Crank Time: 34816
[17:04:11] NETCLIENT:Auxiliary Controller: Attempting to connect to phone at: 192.168.10.100:21587
[17:04:11] NETCLIENT:ERROR: Auxiliary Controller: Error connecting socket: 'Connection refused' (61)
[17:04:11] BLE: TACX queuing grade change to -0.00
[17:04:11] NETCLIENT:send player state sequence number: 16501
[17:04:12] Wheel Rev: 8920 Wheel Time: 40422
[17:04:12] Crank Rev: 4017 Crank Time: 35840
[17:04:12] Setting activity ID to 4457589
[17:04:12] Setting activity name to Zwift - London, UK 01/05/2017
[17:04:12] Setting activity local fit file name to 
[17:04:12] NETCLIENT:Activity Upload: no fit file
[17:04:12] Uploading activity to server -- fit file name = 
[17:04:12] Mouse click at 1183 1385
[17:04:12] BLE: TACX queuing grade change to -0.00
[17:04:14] Analytics logged

 

Any hint or fix for this? It’s really annoying… ;/

 

 


(Stephan Kiene) #20

Same for me on my iPhone 7 Plus: 90 minutes of ride data lost, just a partial upload of a couple of k. No fix for this after 4 weeks? Somewhat disappointing, especially as the upload issues started to happen on the OS X version as well recently.