Unable to download a ride - and it didn't auto-upload [July 2021] [SOLVED]

I completed this ride this morning:

However in companion app it shows with no map and in the website activity feed the link shows with just the website header and footer, nothing else. Any ideas?

It didn’t sync to TrainingPeaks or Strava automatically. I’m using the latest Zwift update.

31 Likes

I’ve also had two races since the update that didn’t sync to Strava. The free rides either side of the events uploaded fine, but not the actual events.

Using Apple TV 4k

24 Likes

Same issue with me after the update on Apple TV 4K, did not automatically upload to strava and I cannot manually upload it either as I cannot click on the ride on myzwift, companion does not load the map and just shows where I placed on the race… big shame too as it was the specialized roval climbing challenge and was the hardest ride to date for me.

12 Likes

So the common link between us all is that we rode events. Mine was a morning group ride with an Australian triathlon group.

I’ll just avoid riding any events until this gets fixed.

Recommend to hit the Zwift support with these details too.

1 Like

I have had the same issues twice today. free rides the .fit file loads to Strava, Garmin, TP. It is group rides where this mornings ride shows 71km on Zwift by a 0:03 sec rides in the .fit file. This evening the group ride in zwift shows 40km but when i click to check .fit file the zwift page does not load the ride. I am using an appletv 4k also

5 Likes

I also rode one of the Specialized Roval Climbing events today and my ride didn’t upload to Strava and I can’t access the fit file, I rode with an Apple TV 4K , I am currently very very upset as I rode my fastest ever time up the Alpe (44min 11sec) and it was by far the best my legs have ever felt in a Zwift event , I hope Zwift resolves this issue quickly so that I can upload my ride to Strava

14 Likes

Same issue here… my race result was not uploaded to Strava; what’s different from folks is I am using iPad, not Apple TV.
I tried manual upload using .fit file, but I cannot access the result even via myzwiftcom and thus I cannot have .fit file.
I hope this will be resolved soon.

5 Likes

Gang - thanks for reporting on this thread. Combining your reports gives us an idea of the extent of this problem. We’re on it!

14 Likes

To access the activity file on iOS and Android you can try this:

Swift Zwift Tip: Accessing Activities and Logs on Zwift IOS & Android

Then you can use the manual upload feature on Strava and if the ride appears without a map, or altogether Strava rejects the file which happened in my case you can run it through this tool and try uploading it again.

EDIT: the problem although similar is not exactly the same as mine and the cited tool is most likely not capable of fixing it.

I had the same issue earlier after completing a group ride on ATV4K. Ride didn’t sync to Strava & Training Peaks and neither can I download the file.

1 Like

Yep, same problem for me and my wife this evening. Race warm-ups uploaded just fine, but the races themselves have not appeared on Strava. Also using Apple TV 4K

Further to this the data in terms of distance time and elevation for my race shows in Zwift as correct, however the power, heart rate and cadence data is identical to the info in my previous warm up ride.

Hope it helps.

3 Likes

Tried this and only a .txt file downloads for the impacted rides. other rides I can download the .fit file It was a good suggestion though

1 Like

Same here!!! I did the specialized roval race using the iPhone. I cannot see my ride with map on the website but I can see the race result on the app, but no map and the ride did not upload on strava and it was my best time up alpe du zwift :sob::sob::sob::sob::sob::sob::sob::sob:

5 Likes

Yeap same problem here raced the New York ZRL Classic race this evening - it shows in Companion app but nothing on Strava ?? Tried manually uploading the fit file & its stating its a duplicate file of my warm up???

3 Likes

Jasmine I lost my (edit 49:28) AdZ time as well to Strava. It is on ZwiftPower though and activities has the fit file but it appears corrupted

I cannot include links of my Dropbox for the files

Any fit file guru out there please have a crack to save my sub 50 AdZ time :sob: I can email you them :sweat_smile:

3 Likes

My Alpe du zwift was 46 if not less :skull_and_crossbones: :scream::sob::sob: please someone save my file !!!

2 Likes

It is still on zwiftpower for me… and on the activities with all the parameters too and a power curve.

I’m pretty sure it is something to do with the fit file generated from the app being corrupted. :sob:

2 Likes

Same issue for me twice now. both Specialized Climbing rides - first on Mountain 8 yesterday & now Innsbruck today. Both Apple TV. Both show up in Zwift Power. Yesterdays fit file in Zwift seemed completely corrupt. todays fit file was the warm up ride (i didn’t do a warm up for yesterdays).

1 Like

For one more sample of working/non-working since the update:

Completed 2 rides today.

The first, a solo workout, everything appears to have uploaded as expected.

The second, the Specialized Roval Climbing Challenge (C), didn’t. It shows up in my activity feed, with all the correct info, in the companion app and the web site. However, if I try to go to the activity, I get “Activity details could not be loaded.” in the companion app (tho the pics I took and the race results are there and work as expected). If I try to load it on the website (https://www.zwift.com/activity/863235292787172400), I get nothing but the page header and footer. Absolutely nothing about the ride itself.

EDIT: Just completed another group ride and the same thing happened as the Climbing Challenge. For both rides, I did no pre-ride warmup, started Zwift session, joined the ride event (8 mins before start for SRCC, 4 minutes for Herd ride) that was on the same world (so no world shift). Using iPad with updated Zwift. I did another Herd ride yesterday after the update and that worked fine, so I’ve had 2 work and 2 not since updating yesterday.

2 Likes

Interesting Brett. Did I assume correctly that yesterday ride you did not ride anything before joint the pen and today you had an warm up ride before clicking “join event” button to the pen?

I have SOME ideas for the zwift engineer.

Both times I have an empty files on ZwiftPower activities because I did not do a pre-ride before joining the pen. I saved my warm up ride and log in again and join the pen immediately.

It SOUNDS like the final file only contains what it is before the pen