Zwift Hub Flashing Red Light

I’ve had 5 emails from various members of Zwift support. They assure me that the my problematic Zwift Hub has been referred to their superiors and the relevant departments. So far no solution has arrived. My red light is flashing quickly and will not connect to the Companion App, so future firmware updates will not be possible. I can ride the bike in game but I’m not sure about how accurate the power is. Yesterday Maria bot dropped me while I was putting out 4 Watts per kg - yet I was able to follow her today for 40km. Something is not feeling right.

So, following on from a few emails to Zwift support I have been sent a replacement unit.
I set it up and checked everything out. Seems a bit more dodgy connecting via Bluetooth, but it does work.
It came with Firmware version 3.8 and told me an update was available. I did the update, with some trepidation, and it succeed. The blue light is solid and the companion app tells me the firmware is up to date. Test rides work, I’ll give it a proper ride after work this evening.
The odd thing is the companion app is saying the firmware version is 3.9. Have they pulled version 4.0? It was the upgrade from 3.9 to 4.0 that broke my original unit and seems to have caused trouble for others, so I think if you’re having issues and they started when you tried to upgrade to 4.0, keep going with emails to support, tell them it’s version 4.0 that broke your unit and they’ll, hopefully, send you a new one eventually.

1 Like

My new one is in transit too. Well done Zwift!
I asked about whether the latest firmware would be pre installed. They said I would have to update myself but they would be there to help. That’s very interesting about v3.9 appearing to be the latest version as I would be nervous about updating to v4.0 again.

Thanks for the update Chris, that’s good news. I’m still waiting for my replacement to arrive but it should be here sometime today. First thing will be to update the firmware and see what happens. I wonder though, if v4.0 has indeed been pulled, could something similar happen with a future update? I hope they get that figured out.

1 Like

Good luck Tony we’re on the same boat, I’m nervous, I hope it doesn’t get bricked again. I’ll keep you posted.

1 Like

Got the new Hub and installed the update. Yep, got 3.9. All working ok now.

Hey all - our engineers have been investigating why some of the returned units did not take the v4.0 firmware update as expected. Thanks for flagging it up to us quickly so we can get to the bottom of things.

I’m crossposting this information to this thread to highlight a few details before updating, and some things to be aware of should an update fail.

Before updating firmware

  1. Verify you’re using the latest version of Zwift Companion. Please check our Latest Version thread , and confirm build numbers on the Google Play Store / Apple App Store
  2. Keep the phone within line of sight of the Hub trainer.
  3. Do NOT let the phone sleep. Be sure your phone is charged fully, or plugged in to AC power.

If you attempt a firmware update and it fails:

  1. Force-close the Companion app and re-open. Rebooting the phone would ensure a clean restart.
  2. Do not press the Forget button in the Companion app.
  3. Do not uninstall and reinstall the Companion app.

If several attempts fail, contact us for next steps.

1 Like

Just got the same problem yesterday. The red flashes every 5 seconds, it looks like solid red but every 5 seconds it flashes for 1 sec.
Tried with support but they told me they forwarded the case to more appropriate team.
The hub worked great the day before but the day after it just froze and this keeps happening no matter what I do.
Phone or PC wont connect it seems like BT is not working.

This is becoming frustrating since I just started recovery from my broken rib injury and thought Zwift could be a reliable training platform.