Zwift Hub Flashing Red Light

Hi, so my Zwift Hub has a flashing red light and I can’t seem to find any information on what this means. The explanation on the Zwift support site doesn’t say anything about flashing red only solid red.

So here is what happened. I got a firmware updated notification on the companion app and I went to install it. This is for the firmware released on Feb 7 2023 v4.0.0. Everything went smooth and installed perfectly, I got the success message and checked the Hub and the light was flashing blue which means it is waiting to be paired so all good there. The next day I went to do a workout and that is when I noticed the light was flashing red.

I opened the companion app and it connected fine to the Hub with no error messages and it showed a green bubble next to “connected”. So I fired up my PC which is where I run Zwift and it connected fine. It seemed to be measuring power and cadence correctly. I started the workout and everything seemed normal although I did feel like power was off a bit since it felt a little easy compared to other days but maybe it was just me because power and cadence were consistent with no dropouts of any sort.

So not sure what is going on, is the hardware about to fail? I contacted Zwift support but got some generic replies with instructions on how to get a good BT connection and how to update the firmware so pretty useless. I replied with more details and questions but I have a feeling it might take a while before I get some real support.

If you are having the same issue or have some insight, would you mind sharing? Thanks!

I have exactly the same issue and ‘support’ from Zwift. Works but power feels off.
Nothing helpful from them yet, just ‘leave it off, delete companion app, reinstall companion app and turn it back on’ which didn’t help at all.

Sorry to hear Chris, I will let you know if anything changes on my end, for now I’ll just deal with support and see. It just seems odd to me it would be right after the update so maybe it’s just a bug that needs removing hopefully but for now I’m not sure how to deal with the power issue. I will have to test tonight and see if it really is over reporting watts.

I have been told by support the unit is going to have to be replaced.

1 Like

Oh wow! What a bummer, I hope they are taking full responsibility…

They’re sending me a replacement so it looks like it. I’ve told them I expect it to be brand new and I will need to check it works before I return my existing one.

Ask if it will come with the latest firmware installed so you know it works

Good idea, I hope you don’t have to wait too long. By the way I just got a reply from support and they are ignoring the issue with the flashing red light and pointed me to another pointless article on how to perform a spindown calibration even though automatic spindown calibration is one of the features of the new firmware lol I’m trying to be patient but it’s hard when they take so long to reply and when they do it’s with some useless stuff.

Good idea, although I was going to do that and make sure everything works before I return my existing one.

What concerns me is there doesn’t appear to be a method developed to rollback the firmware or even attempt a repair if it goes bad. Jetblack, at least, offers an article to use the nRF Toolbox (develop for the chips inside) and a link to the firmware to attempt a recovery. We seem to have a situation where if the update breaks it will require a replacement unit, to resolve.

Also, if there are ‘features’ in this build that would result in the firmware update being pulled, there is no back out plan to restore the previous one. Users would have to wait for another firmware update to be available.

Of course, not all users are technical and not all users care, so would struggle with the steps above but it does provide an avenue for users to explore and attempt themselves, rather than waiting on a new unit. Ideally the routine would be available in the companion app - restore previous firmware, attempt repair, etc!

1 Like

I agree, it doesn’t seem like a viable business plan to just replace units without even giving customers the chance to attempt a fix.
I’m really surprised they said they’d do this without even seeming to do any investigation.
As long as I get a new working unit I’ll be happy but they surely can’t sustain this if it’s happening to lots of units

I posted in the other thread that I’m having a similar issue since upgrading to v4.0.0. It won’t stay connected to my PC anymore (says “No Signal”) but it connects fine to my iPhone. I can connect it to my work’s MacBook Pro and do a ride okay although I did notice that it occasionally flashes purple. I uploaded my log file to zwiftalyzer, but it doesn’t show any bluetooth dropouts or trainer resets.

I guess I’ll file a support ticket, but based on the comments here, it doesn’t seem very promising. I think it’s clear that v4 introduced some issues.

I am having the same issues with my Hub, it has worked flawlessly up until the V4.0.0 firmware update. My Hub is having issues with connection to the game. It is blinking blue then purple. Initially my laptop wasn’t recognizing the Hub at all. Unplugged the Hub and restarted my laptop and was able to get it paired, then after a while i got a disconnected notification mid group ride and could not get it reconnected. Any answer from support what may be going on?

I finally got a resolution from Zwift support. Same as Chris above, they will be replacing my unit. They said it will be brand new, but that I may need to update the firmware once I get it so I don’t know… but kudos to Zwift for stepping up and making things right. I have to return the old unit within 14 days after I get the new one, they sent a return label for that. They’re also saying that at this point there is no way to revert to a previous firmware so I guess that’s why they’re stuck replacing them but I don’t know how true that is since according to another post Jetblack is doing it with the Volt which is what the Hub is based on.

Dale I would contact support just tell them that your Hub got bricked with the new firmware. They’ll send you a bunch of unhelpful articles the first couple emails but eventually they’ll tell you they’ll send you a new unit. Hang in there!

I too have the deadly red flashing light. The only thing that doesn’t seem to be working is that I can’t connect the hub to my phone anymore - so presumably would never be able to update the firmware again. I’m contacting support as my next job.

It is an odd fault, mind connects to my phone ok and says firmware up-to-date, and still connects to my pc and works (so I can ride) but the power feels off (possibly the auto-calibration feature?)
I’ve been sent a new unit, which should arrive in the next couple of days, and been told I have 10 days to test it before returning my existing one.
Plod through the support process and you’ll hopefully be sent a new one too.

1 Like

Thanks David, I haven’t dove into it to much. Initially i wasn’t able to pair aything to my laptop. I was just stuck on the pairing devices screen, with the hub flashing blue then purplish/Red. So started trouble shooting. Unplugged the Hub and plugged back in with the same result. Then escaped from the Zwift app and restarted still the same result. Started to get a little frustrated. Next i restarted my laptop as i usually just put the laptop in sleep mode because i only use it for Zwift. That seemed to work. I was able to pair all devices and got in 2 hours of riding. Then I got a connection disconnected. Zwift was still working on screen but all devices, power, cadence and heart rate went blank. Tonight i am going to go through the standard protocol of uninstalling and reinstalling everything and go from there. Fortunately the weather is looking decent in my area or the next 3 days. Beyond that i may get a little irritated if i can’t use the Hub.


went to do a ride yesterday and the hub is stuck with a slowly blinking red light - it is not showing up either on the Zwift game ( PC w11) or on the ZC on my phone ( which says unreachable) - I have tested various Bluetooth options and there is no signal from the hub. It has been working OK up to this point ( only had a couple of weeks). I was not in the middle of a firmware update ( at least to my knowledge) and have tried turning off an don again - noting. I have opened up a case with support and am waiting but they refused to tell me if this was a common issue. Really frustrating - I fear will need replacing but hope this can be done quickly - anyone else have the same issue?