Can't update Zwift Hub firmware in Companion app [Android and iOS]

Recently i got zwift hub, on app it shows that update is aviable. When i try to connect zwift hub to companion app, it dosnt connect. I cant pair zwift hub with app to update it.
It shows on bluetooth aviable devices zwift hub, whan i try to pair, it says an app is needed to use this device, but i have companion app…

Good morning @Martins_Odins

Check that the trainer is not connected to any other app.

Also go-to the Bluetooth settings in the phone and forget the trainer.

Trainer is not connected to any other up as the blue light is blinking showing it is ready to pair.
How to find those settings? I have android phone, i searched everywhere :frowning:

Settings - Bluetooth & Device - Bluetooth - previously connected devices - gear :gear: next to the trainer.

Right, i got zwift hub paired with my phone now , but its not showing zwift hardware on companion app.

Repeating @Gerrie_Delport_ODZ …disconnect the Hub from the phone then use the Companion App.

The phone connection is blocking the Companion App.

if i disconnect zwift hub from my phone then how Companion app will find zwift hub?

The app will use the phone’s system to find it. If the phone is already connected, due to BT limitations, the App is blocked. Somewhat non-intuitive…i have gone through the same thoughts you are having. just the way it works.

You have the advice. Please go try.

i dont have that zwift hardware tab showing up in companion up :slight_smile:
I switched on zwift hub, its blinking blue and companion ap is open, nothing is happening, that zwift hardware tab is not showing up.

I do not have a Hub so now outside my realm of experience.

I think others on this forum have deleted the app and reinstalled and tried firmware updates (although you have to connect first to do that). Try that. If still no joy, you should contact Zwift directly.

Go to Bluetooth settings on the phone, delete it there, start companion app.

on adroid phone?

Yes, it’s worth trying.
No guarantee, but if it doesn’t help contact support.

Still no luck, hope zwift support will help with this, tryed everything, that hardware tab is not showing up. Tryed on two other phones as well, no luck.

I have the Hardware tab even though I don’t own any Zwift hardware … are you sure you have the most up to date version of the Companion App?

1 Like

Yes, i reinstalled it more than few times :frowning:

You should check the version number in Settings, About. The most recent version is 3.40.0. It requires Android 9 as far as I know.

Thats the version i have.

It look like bluetooth is turned off?

the bluetooth symbol doesn’t always show up on android. Not to say it isn’t off but you wouldn’t necessarily be able to tell from that screenshot