Pairing rejected by Zwift Hub


Zwift Hub refuses to pair with my Companion App. Which makes it impossible to update the hardware in an attempt to fix the 5-10W when I stop pedalling. But I’ll stay on the first issue.

When I want to pair, the light of the Hub turns solid blue, it tries to connect but than “Pairing rejected by Zwift Hub” appears on my phone.
I’ve already tried everything I could find:

  • Restarted everything
  • Most recent Companion App, previous versions, …
  • I can’t possibly give more permissions
  • Connected to the Zwift game on pc, disconnected there
  • Turned off all other Bluetooth devices
  • Tried pairing via OS and via Companion App itself.

The HUB does not show up in the CA but I can find it via Bluetooth. It just refuses to connect.
Please help, the false wattage readings takes away racing fun and makes me doubt all my efforts and results.

FYI, I’ve updated my Hub via the CA two (?) months ago so back then it worked fine.

Kind regards

Hi @Mathieu

A little clarification please: when you say it refuses to pair to Companion app - do you mean 1) for the purposes of updating the trainer’s firmware or 2) when using the Companion app to bridge your trainer to the game app or 3) both?

If you’re able to achieve #1 - what version of the Hub firmware is currently installed? Instructions here. Please note the part that says Companion app requires you give it Locations permissions in the OS settings. Without Locations permissions, the Companion app can’t use the Bluetooth radio and may cause your symptoms.

One of my colleagues who’s an expert on the Zwift Hub will be in touch with you directly. Please check your email inbox.

Hi, to clarify for other readers:
With ‘it connects’ I meant that the indication light on the Hub stops blinking and shows continues blue. A (system) pop up appears to pair the Hub when I open ‘hardware’ in the CA.
At no point does the Hub actually show up as a device in the Companion App. It always states that the Hub rejected my pairing attempt.

I did succesfully update my Hub to v4.0 (limited roll out) via the CA. That’s when the non-zero power reading issues started and I’m often not able to aerotuck. I’ve set some PR’s since but can’t trust that those where accurate readings. I’m therefor hoping v4.01 will fix these issues.

I’m since no longer able to connect the Hub in any way to my phone or CA.

I’m on Android v11, Xiaomi. The CA has all the permissions I can give it. Location is on and the app has permission to use it whilst running (highest permission available).
The ‘nearby devices’ thing I read somewhere is only applicable from Android v12 onwards.
I’m on the latest app version.

I’ll respond to your colleague directly!

I had a very similar problem when I attempted to update from 3.9 to 4. Zwift sent me a new Hub. That new hub was okay for a while, then got the mysterious blinking red light issue. Zwift then sent another Hub. I’m on my third Hub, wish I had bought a Wahoo .

I solved the connection issue!

I had to literally block the pairing request when prompted, to make the pairing…
Guess it’s the OS vs App pairing thing.

So far, the inaccurate power readings do not seem to be solved. I’ll keep updating.