DFUError(rawValue:25) Unable to connect to Zwift Hub

I have a brand new Zwift hub. I have been trying to update the firmware ( to 4.0.1) on my 2week old Zwift hub. The blue led light remains on suggesting that the hub is paired. When I go to the companion app and click more to update the firmware the hub does not appear ( all the while the blue light remains on). There are no other blue tooth enabled devices nearby or on. I have followed all of the steps on the troubleshooting page and I’m no further forward. I have occasionally been able to click to update, it brings up the download bar for a couple of seconds then an error message appears. This is extremely frustrating as I would expect a brand new trainer to work perfectly. The Zwift companion app is the latest version. I’m connecting via an iPhone XR on the latest iOS. Normally I run Zwift on Apple TV 4th gen. Any advice would be very much appreciated. Thanks. I have attached the error message which tells me that I am connected to the trainer but I’m clearly not - this is driving me nuts.


Hi @Iain_Thomson_DBR welcome to Zwift forums.

Shuji at Zwift HQ here. I looked at your server logs and see that your Hub trainer was on firmware v5.2.0 at the time you wrote in. For a brief time two weeks ago, we rolled back to make v4.0.1 the publicly available FW version. This is probably why you were seeing that error.

Subsequently, we completed rollout of Hub firmware v5.2.2 and that is the most current version available to download. Were you able to upgrade to 5.2.2?

If no - would you try power cycling your smartphone, fire up the Companion app, and attempt the firmware update again? Please let us know if that resolved the connection issue?

Good morning,

Thanks for your response.

Yes, just before I went to bed last night I tried once last shot at updating the firmware and it worked fine. Very strange, I don’t know home many times I followed that exact procedure and thankfully this time it worked.

Thank you.