Zwift Hub Autocalibration [Firmware v4.0]

I have been told by support that the unit is going to be replaced.

Just received a new Zwift hub, to replace my unit that failed on the upgrade to firmware v4.0, and it came with firmware v3.8 and told me an upgrade was available. I did the upgrade, it succeeded and now says Firmware is up to date and the version is 3.9
Have they pulled 4.0?

1 Like

I decided to hold off on installing v4 given how many issues I was seeing others have. I’m no longer seeing v4 as available on Companion either. I really wish Zwift (@shooj ) would respond here with more information. I’ve tried dealing with support by email, but that’s basically a joke.

1 Like

I got my Zwift Hub 4 days ago and firmware update was at 3.9. Checked yesterday and no change.

I spent a bunch of time Friday on Zwift support chat trying to ask why I couldn’t update to 4.0 even though I had been getting the update messages all week. I was/am not able to manually calibrate so I thought 4.0 would help me despite my reservations. None of the support staff I chatted with knew (or will willing to say) that the firmware rollout was suspended (presumably due to these issues), but a reddit post late Friday confirmed that it has been pulled. Now I am glad I didn’t update when it was available to me. Sorry to those who took the plunge and regret it.

Hey everyone -
We’ve been investigating why some returned units are not taking the firmware update as expected. Thanks to all those who’ve been working through this with us! There’s a few steps we’d like to detail

Before updating firmware

  1. Verify you’re using the latest version of Zwift Companion. Please check our Latest Version thread, and confirm build numbers on the Google Play Store / Apple App Store
  2. Keep the phone within line of sight of the Hub trainer.
  3. Do NOT let the phone sleep. Be sure your phone is charged fully, or plugged in to AC power.

If you attempt a firmware update and it fails:

  1. Force-close the Companion app and re-open. Rebooting the phone would ensure a clean restart.
  2. Do not press the Forget button in the Companion app.
  3. Do not uninstall and reinstall the Companion app.

If several attempts fail, contact us for next steps.


Is the auto calibration only done when riding with Zwift?

Currently I use my bike computer (Garmin Edge) for some trainings and I was wondering whether calibration is needed there or not.

1 Like

One of the first things I was advised to do was delete and reinstall the companion app!
That obviously didn’t work and I now have my replacement unit up and running.
I am, according to the companion app, up to date with the firmware, which is 3.9. Does this mean I don’t have auto-calibration at the moment?

Once the Hub trainer has been updated to firmware v 4.x or higher, the trainer itself has the ability to autocalibrate. Autocalibration will work with other apps, in other words/

Correct. We are rolling out firmware v4.0 in phases. It will be available to all Hub owners to allow autocalibration soon.

1 Like

9 posts were split to a new topic: Heart Rate Monitor not paired to Hub Trainer after firmware update [v4.0] [February 2023]

I have owned my Hub since late October and it has worked flawlessly up until the last firmware update. I have the latest update on both Zwift and the Hub. Actually if I remember correctly both update were done on the same day. I am using a windows 10 pc connected with a ethernet cable and a Android tablet for the companion app. I am continually losing the connection between the Hub and my computer. The power, cadence and HR just go blank. It happened 3 times last night while trying to ride with Maria. The only way i have been able to re-establish the connection is to exit the game and restart and it works for thirty minutes and the process starts over again. I am also unable to connect to the bluetooth straight thru my computer, i have to run it through the companion app. I have tried turning blutooth off the on to re-establish the connection and making sure there is no interference between the Hub and the computer with no change. Any help or suggestions would be appreciated.

Contact support. You may need a new trainer.

I’m running 3.9 firmware and having a problem. If the flywheel is spinning quickly (on a descent for instance) and I stop pedalling, it is still reporting watts. Over 7-10 seconds it will drop and then hover around 20w before it finally drops to 0. Not ideal in a zwift race when the pack are all in a supertuck catching breath and you cant because the power is stuck on 20w.

I don’t know if this is just common with the Zwift Hub or just a fault with my turbo. I’ve tried both Bluetooth, bridging over the companion app and also Ant+ on MacOS, Windows and Android versions - same issue across all platforms. I’ve tried a different turbo (Kickr) and that works fine so its obviously the Hub. I hope this is something that can be addressed in a firmware update.

1 Like

I performed the firmware upgrade, and it appeared to work. However, after the update, when I attempted to select the Zwift Hardware menu option, I got a popup asking me to pair my phone to the zwift hub (a Bluetooth pairing request). I clicked ‘okay’ on that popup, but it just kept redisplaying the popup until finally it just showed my zwift hub as disconnected. It gave me the option to ‘forget’, and unfortunately I clicked that thinking that if I closed the companion app and reopened it, that the Zwift Companion app could rediscover the device.

Now when I click the Zwift Hardware menu option, I get a window saying ‘No Zwift Hardware Found’ , and the bluetooth pairing request cycle starts again. Eventually the popups stop displaying leaving me with just the ‘No Zwift Hardware Found’ message and a button to retry. The retry button just repeats the Bluetooth Pairing request popup.

Interestingly enough, the zwift hub led does go from a blinking blue light to a solid blue light while the bluetooth pairing request popup is displayed, but eventually will start blinking blue again .

I reinstalled the Zwift Companion and it is the current version (it was the current version before the problem occurred as well). I do have the location permission for the ZC set correctly as well.

Any help would be appreciated. I am able to ride with the current state of this problem, but would not be able to update firmware if a new version came out later this year given my Zwift hub doesn’t show up anymore as a hardware device.

@shooj Is there any news on when firmware version 4.0 will be rolled out to all? I have my replacement trainer but I’m reluctant to return my old one while the new one is still on v3.9 I would like to be able to get my replacement trainer on to v4.0 and test everything works first but it isn’t available

My companion app was showing a new firmware is available last night. Maybe a new build is making the rounds. Not installing it yet, though.

I just updated to firlware version 4.0 and now the hub is not connecting anymore, it refuses all bleutooth connections and the blue light keeps flashing…
Tried everything suggested here.

Same as Douglas above with one exception - I could only ride by replacing the bluetooth dongle with an ANT+ dongle. I hope this can be fixed so I can use bluetooth.

What is temporarily working for me is connecting to the companion app on iOS and then setting zwift to use the companion app instead of directly connecting to the hub. This can be done by selecting the gear menu on the top right. Not sure if that’ll work for you, depends on your setup and the problems you’re having.

Just want to report the same problem after the update. Zwift will often show 2-5W causing me to not aero tuck…
And to be clear, this was not a problem before the update.

Now I’m starting to doubt my recent PR’s as well :frowning: