Zwift crashing on startup [AppleTV] [1.30] [October 2022] [SOLVED]

Since the last update I can’t get Zwift on Apple TV anymore, I’ve re installed it twice, reloaded Apple TV as well but no luck any one else having this issue


Yes. Apple TV HD. Latest version of OS and Zwift.

1 Like

What exactly happens? Can you explain in more detail, please?

When I log it it goes into to the Zwift screen then stays there for a bit the shuts down back to my Home Screen


Same for me. Blue Zwift screen then back to main Apple screen.


Are you both running on the old Apple TV HD? Not seeing this on my Apple TV 4K.

I have the Apple TV HD with 32 GB memory. Must be about 3 or 4 years old now. Worked flawlessly until latest update.


Same here with my AppleTV HD!

1 Like

Any chance that your ATV is not on the latest TV OS version? Might be worth a check.

Be nice if it was that, but just checked and I’m on latest version and Zwift not loading. Working fine yesterday evening before the update.

Edit - following advice, Uninstalled Zwift, rebooted ATV, and reinstalled Zwift. All working fine now.

1 Like

TL;DR: you’re going to need to provide more details if you want help.

I would also suggest a complete factory reset of your ATV. While I’m on a Gen1 4k box, about once every year or two it needs that kick in the ■■■■.

I would raise this as an issue with Zwift support directly. It may well be an issue specific to the older Apple TV HD.

Have you tried force-quitting the Zwift app and starting it up again? Unplugging the ATV for a bit and then booting it up again? Deleting and re-installing the app? Kind of grasping at straws here, but these options often fix things for reasons I do not understand.

1 Like

Word on Zwift Riders Facebook group is that this process worked for one user:

  • Uninstall Zwift
  • Power-cycle Apple TV
  • Reinstall Zwift
  • Repeat

same issue - rebooted the apple tv, checked the 1.3 version, still crashed at title screen.

Zwift team - please test your builds on ALL supported devices before pushing them out.

edit: why can I not vote this up?


Did you try the workaround I mentioned above?

Did you click on the word ‘Vote’ at the top of the thread?

1 Like

If you have this issue, please confirm which model of Apple TV you have.

Deleted Zwift and restarted ATV twice. After the second deletion and restart had to open Zwift twice - it finally loaded.

FWIW: I just updated my ATV 4K. No issues with the update and Zwift started normally.

1 Like