Zwift crashing on startup [AppleTV] [1.30] [October 2022] [SOLVED]

Apple TV HD

I clicked on the number. Thanks for the tip.

@shooj It’s starting to look like we’ve got a problem specific to the HD model of Apple TV and 1.30.

1 Like

UPDATED October 19
No need to send in more tvOS crash logs to Zwift Support. Please jump forward to thie post for the latest.

Thanks for flagging this up, everyone. We need your help to get the crash logs on your AppleTV. Please email us your tvOS system crash logs. Text files like this can’t be uploaded to the forum for malware risk reasons.

On AppleTV this is how you get the crash log

Then: contact Zwift Support. When you first make contact with the AI bot, say that you have a crash issue and want to email log files. This will funnel you faster to the appropriate team.

Thanks for your help with this!

3 Likes

‘Most reliable’. ¯\ (ツ)

2 Likes

Same issue…Apple HD TV…all up to date …click on the app … nothing happens…after 30 seconds screen goes back to main menu…I’ve reinstalled twice no joy…trying again…also reinstalled apple tv…

edit 3rd attempt at reinstalling -still no joy

1 Like

they need your log from the ATV

I’m struggling to find analytics in the settings…

Atv 4k just updated and done 50min workout no probs here

I think it’s ATV’s settings not Zwift if that helps

Yep found it under general - privacy… problem is I can only share it via Airdrop… unfortunately I dont have any other apple devices to share it with then e mail… apologies I’m new at this had Zwift for 11 months and it’s been flawless up until this issue…thanks anyway

After updating on my ATV, Zwift will not run. It tries to load (I get the light blue loading screen) but after about 30 seconds the app crashes. I’ve tried restarting ATV but I still can’t get Zwift to run. My ATV software is up to date. :frowning:

Have you tried this process?

  1. Uninstall Zwift app
  2. Reboot Apple TV
  3. Reinstall Zwift app

See Zwift crashing on startup [AppleTV] [1.30] [October 2022]

I’ll try later when I get home if no one gets it before me.

I’ve loaded latest version to ATV and now it won’t load. Get the blue loading screen then it just crashes and goes back to ATV home screen. Updated ready for tonight’s ZRL and had to race it on an iPhone instead.

1 Like

Tried this already, no luck. :-1:t3:

1 Like

Same boat here. Apple TV, updated Zwift and now crashes back to Home Screen when trying to launch Zwift.

Looks like a wide spread issue.

1 Like

Alternate (and terrible) solution: Get an ATV 4K. :wink: