AppleTV Crash

Since the latest update (which was applied to my AppleTV on 5/2/2020), Zwift has crashed on my AppleTV 3 separate times. Once during a race, and twice during group rides (including one I was leading). This has never happened before the latest update. I have not changed any settings, etc. and am connecting to zwift the same way as always.

When the crash happens it appears to turn the Apple TV off completely, and not just close the app.

Edit: I’m using an AppleTV 4K. Interestingly enough, 2 of the crashes happened at roughly the same location: about ~5 or ~6 miles into the desert along the Tempus Fugit route.

Would appreciate any help looking into this!

—Brandon

I have the same issue as well and it makes Zwift unplayable. The screen will freeze and get green stripes across it. Im still waiting for a fix as well. It seems to be a more common problem lately

For what it’s worth, I run ATV, also, and have not had any issues. Any chance there is something not working with another part of your setup? Is your ATV OS up-to-date? WiFi has a strong signal? Power cord working OK? Any issues with other apps you might be running on your ATV? Just trying to rule out issues outside of Zwift, as this does not appear to be a widespread issue.

Nigel what resolution are you running zwift at? 4k, 1080p?

I have tried all the common fixes you and others have mentioned in the past and was unsuccessful. I think the latest updates are causing the crash itself

1 Like

I will have to check, but I’m pretty sure it’s 1080p. I don’t think Zwift allow/recognize 4K on the ATV (not enough processing power, sadly).

Update: I just check the Zwift setting on my ATV and it doesn’t appear there is even an option to select a resolution, so I just have whatever Zwift is offering. Perhaps this is because my TV is only 1080p, though.

All good questions. My AppleTV is used only for Zwift, and never once had an issue until this past week (>1 year). I think everything is up to date, but may run through again I guess. WiFi signal is also good.

Clearly, then, it’s time to buy a top-of-the-line gaming computer! :rofl: :rofl: :rofl:

Had my Apple TV 4K for over a year and never had a crash, been faultless. However, after updating Zwift recently it crashed last night, screen black and Apple TV had switched off. Have sent the crash log to Zwift support, hopefully they can advise and fix the issue.

So I’m not saying I solved it, but I found an interesting article on Apple TV matching frame range and dynamic range from the source. This setting was defaulted to “off” for me, and I turned it “on” last night. Everything worked fine in a race and ride this morning.

I’m hoping that the last update altered something to do with frame rate or something, and that this “match” will resolve it. Time will tell!

1 Like

Thanks, i’ll try it too!

Been using Apple TV 4K since it came out. No issues. I will check and see what that setting is on my Apple TV when I do my lunch session and post back.

As for 4K vs 1080p … Zwift renders the on screen HUD in 4K, but all the riding aspects are limited to 1080p.

edit: I checked my “matching” setting and it is OFF.

1 Like

I tried adjusting the frame rate and dynamic range as suggested above and it didn’t fix the issue. Apple TV still crashed. Anyone have any other suggestions?

If we all contact Zwift support it will highlight the issue and likely get fixed

If you haven’t done so already:

  • Double check that you are on the latest Apple TV OS.
  • Double check that your Zwift app is also updated.

Do both of the above manually. Do not depend on auto-update which might be disabled. Even if enabled, it is not immediate.

Thanks Lin,

I’ve tried all of the fixes mentioned above and in other posts. Apple TV 4k was working fine until an update about a month ago for me. Zwift is now unplayable. I don’t think its overheating because I’m in a well ventilated room with a fan and apple tv is cool to the touch. Today Zwift crashed on me in game in the menu system. Don’t know what else to try

Agree, Im having exactly the same issue since the latest update. Annoying.

David. how did you find the log? I need a fix as well!

Thanks for the tip Brandon. Im hoping its a solution!

Last ditch suggestion would be to delete Zwift and then do a reset of your Apple TV before reinstalling Zwift.

To access crash log on Apple TV 4K, tvOS 13.4:

Go to settings, general, privacy, analytics data. Scroll to find the log, mine was called Zwift-2020-05-06-184300.ips. Click it, then share. You’ll be able to air drop to an iPhone, iPad, for emailing to Zwift.

I’ve not heard back yet from Zwift support, guess they are very busy. Going to do a full reset and reinstall Zwift.

2 Likes