Zwift crashing? [April 1 2024]

Hi, I’m using MacBook 2014 on BigSur. I can login as usual and select the event I’ve signed up to. When I click on start ride, Zwift crashes just as it’s about to take me to the start. It’s done this multiple times this morning on more than one event. I’ve not previously had any issues (last used it on Friday 29 March) and have not changed any settings on my Mac. I’ve not updated my Mac in any way and software is showing as fully up to date. I have 38GB free on my hard drive and have uninstalled/reinstalled to Zwift App. I do not use a VPN. Any ideas?

Good advice, I had no helmet. At the moment I think that Monterey 12.7.4 and Zwift do not find together

1 Like

Same issue. Load up and click start ride and Zwift crashes repeatedly on MacBook Pro 2020
Resorted to iPad and in the end which worked fine

Zwift crashes since I’ve updated my Mac to Monterey 12.7.4, checked security permissions, Zwift has access to the documents, no change. Tried full disk access, no change.

Was able to get into group ride. But screen glitching hard. Black flashing blobs. Tried removing hat and that crashed the game. So I restarted app and put the hat back on and glitching Is back…

1 Like

My last successful Zwift ride was 3/23/24 and when I tried to ride the Big Spin this morning (4/1/24) Zwift would crash as soon as it showed my avatar. I tried multiple free rides and it crashed when loading the avatar/world. I was able to briefly watch others ride with the “Just Watch” feature, but as soon as I clicked “Back to Me” it crashed.

Computer and Zwift info:

I tested it on my Google Pixel 4a with the latest version of Android and noticed strange graphics, seen here:

1 Like

I have the same issues. Worked fine yesterday at 10pm, today it stopped working.

Same issue here. Never had any problems in the past.

App crashes when loading any world. No difference whether choosing free ride, group ride event, etc. I’ve tried about a dozen times to reboot and relaunch in different ways. About half the time the app does not recognize my Ant+ devices.

MacBook Pro 2014, Big Sur 11.7.10. All OS/Zwift updates have been applied.

Yeah, same issue here. I’m assuming it’s because my ancient MBP has no sense of humour…

1 Like

Sorry - wasn’t able to check today, I had food poisoning. :frowning: I’ll try tomorrow.

I have 12.7.4 ready to be installed. So far on 12.7.3 on the Xeon X5690 / RX6600XT Mac Pro 5,1.

I wonder if changing the local clock to something before or after April 1 would do anything…

Bonjour, voilà la raison du crash

I have managed to now load Zwift and drop into a world but the graphics have gone mad glitchy. Can’t attach video here but have one to hand if needed

Le casque virtuel se met automatiquement à la place du casque Zwift et provoque la crash

I changed the clock of my Mac to North American time, still crashing. If I choose just watch, Zwift shows me the world with totally disturbed graphics. Closing back to me crashes Zwift.
Nothing one could do individually, let’s hope Zwift will fix it soon.

It’s still April 1 in North America. I’m not sure if a local clock change to a day other than April 1 would resolve it but it would be interesting to see.


As of a few minutes ago we have disabled the April 1st holiday effect for Android, MacOS, tvOS, and iOS. These crashes should no longer be occurring, as well as the reported visual anomolies.

We will be looking into the root cause in the meantime to make sure this doesn’t happen again.

Thank you,


This issue is probably also related to today’s reports of visual anomalies on other platforms such as Android. Given that the feature has limited value, I suggest turning it off globally.