Zwift crashes on startup or minutes into ride // MacBook Pro

Hi there,

Hoping someone has the answer for this!

For a bit, Zwift was crashing on startup when it pairs with my bike. Now that’s fine but it crashes consistently during my ride, often around 5 minutes in, but sometimes could be 15 minutes in, or even later, but the crash almost always happens.

I’ve read through the crash guide/Mac Catalina guide on Zwift and it didn’t help. I also emailed Zwift support awhile ago and haven’t heard back. I searched the forum and found a few people with similar issues but no solutions listed. Feeling pretty anti-zwift right now, especially due to the lack of reply from their support staff. Anyone deal with this and know what’s going on?

I have:

MacBook Pro (13-inch, 2018)
2.7 GHz Quad-Core Intel Core i7
16 GB 2133 MHz LPDDR3
eGPU – Razer Core X with Radeon RX 5700 XT 8GB 256-Bit GDDR6
Catalina 10.15.6 (19G2021)
Wahoo KICKR bike (I use ANT+ on a USB extension under the bike bc bluetooth sometimes drops signal)

Catalina document folder access granted unless there is more to do that this+comp restart.


Have you tried running without the eGPU? Wasn’t AMD having serious driver issues earlier this year? Are the Radeon drivers the latest? What about overheating issues with the MacBook. There have been a spate of people in the last six months with MacBooks overheating. Several have reported having problems solved by adding cooling to the MacBook.

The other solution to this problem is an Apple TV 4k. There maybe a new higher performance ATV released at the October phone event.

All fair points. Thanks for the advice!

I use the same set up for 4k video work daily without issue (and that stuff is pretty darn taxing). I don’t think it’s a performance issue. The crashes on startup suggest it’s not a heat issue either but could be a driver issue. Will google more there.

Also, my monitor is only 2560 x 1440 (2K).

Maybe time for a PC, then I can finally use that Veleton beta invite. :wink:

I’ve got two MacBook pros, one from 2015, one from 2020 (a work machine). On each, Zwift causes the fan to blow and the case to heat up. I don’t understand this, since it runs fine on a lowly iPad, or for that matter, my old iPhone SE (the iPhone-6 version).

@Eric_Nichols Try disabling the eGPU when running Zwift might not have the necessary support for it.

@Daniel_Connelly_LKHC I too have multiple MacBook Pros, the newest of which is a mid 2015 model. The fan kicks into high gear when running Zwift. It has done this since 2015. This is normal. That said, I have never had Zwift crash. Currently running the latest Catalina.

Thanks – when the computer case gets too hot to touch I worry about stressing the system. Bad things tend to happen to semiconductor electronics when you run them hot (except high-power electronics, such as automotive…). But there’s thermal sensors which would shut the system down. So it’s probably fine: there’s a lot of Macs out there and they’re successfully running Zwift, clearly. Strange, however, my humble iPhone runs the code fine, on a crappy battery.

There are different degrees of thermal damage, and it’s a function of both time and temperature. Anecdotally, while I didn’t have problems with crashing, in the ~4 months I used my MBP for Zwifting, its display developed a contact problem (faint stripes on parts of the screen more or less visible depending on the color, not enough of an issue for my use to bother fixing) which I’m pretty sure had something to do with the thermal load. I have a CPU temperature widget in the menu bar, and whenever I open Zwift, it goes straight to 70 C before even getting to the pairing screen.

Hi Everyone,

Thank you for the ideas! I will give all of them a try.

Interestingly my set up with eGPU worked for 5 months without incident.Then I actually remeber a Zwift update coming through mid summer and that’s when it all started. I installed an OS update a few weeks later thinking that might help, and it didn’t.

So overheating was never an issue for me. Could be part of the problem, but my gut says it might be something having to do with a Zwift update and the drivers for the graphics card.

I do wonder if PC is just the way to go. Has anyone gone from MAC to a dedicated gaming PC for zwift? Any models you suggest?

You should take a look at this

Dedicated gaming PC is perhaps not the best option, Zwift is a little bit special…

I use an 8 years old PC, upgraded just the GPU (Nvidia GTX 1650) and have Ultra graphics with no problems. HDMI to a 55" TV, using Companion App.

Win 10 and GPU driver always up to date!

Ride on!

Weirdly Zwift is now working totally fine, no software updates that I can tell. Had a few longer rides, used eGPU, and nothing went wrong.

1 Like

Well I am now having the issue. Usually 5-7 minutes in now…I have updated my Software. Don’t think its overheating because it cool in my garage and it happens early…
Forgive my ignorance but how do I disable eGPU and what does that do for me?
Good news TR works fine…

eGPU is external GPU. You may or may not have one depending on your Mac.

When you say you “updated my software”, what are you referring to? Mac OS X or Zwift or both?

Both. Had recent Zwift upgrade. The crashing started. So checked Mac had Mac upgrade to Catalina Allowed folder access. Crashed again. Erased and re installed Zwift. But crashed again. Wondering if maybe I only partially erased Zwift. May try that again. Any other ideas?

You can remove Zwift by dragging it to the trash can. Go to Applications, find Zwift and drag it away or right click and select “Move to Trash”. That should be sufficient, but you can also go to Documents and rename/remove the Zwift folder.

The fact that Zwift is crashing mid ride makes me think it is not Zwift and more likely your Mac. What model Mac do you have? Are you connecting via Bluetooth or ANT+?

1 Like

I have found that even if your mac has the right folder access allowed (per zwift guide on what to do), it still may not work. You basically have to remove zwift fully, then install again, and click yes when you get the Catalina prompt. I have two machines and on one I never got the prompt, the folder was checked, but it still crashed. Clean install fixed everything for that one.

1 Like
Model Name: MacBook Pro
Model Identifier: MacBookPro13,2
Processor Name: Dual-Core Intel Core i7
Processor Speed: 3.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB
Boot ROM Version: 428.
SMC Version (system): 2.37f24
Serial Number (system): C02T31G9HP49
Hardware UUID: 76B4A627-D500-518A-9260-2DD751FE54A4

Running Catalina 10.15.7
Using ANT +.

Just did a complete uninstall reinstall will see.
Whats fustrating is I really haven’t had any issues outside the occ wifi glitch or 2 sec ant drop till now.

Trying complete reinstall funny didn’t ask me for folder either but it was checked…?going to give it a shot in a minute

So that didn’t work.
Nothing in the crash reports section on Zwift but on Bluetooth which I was not using? I didn’t have it off though. Not heard anything from Tech support email I sent the other night.
Ran workout on phone flawlessly

If you’re not using Bluetooth, then turn it off and try again.

As for resolving Bluetooth issues: