Trying to Identify whether Zwift or Mac are the issue

In the past week, I’ve noticed a strange issue when after about 15 or so minutes of running Zwift I begin to have the occasional frame studded. Eventually, as time progresses it gets more and more frequent to the point where I’m getting less than 1fps and character models won’t even load in properly (floating bike, glasses, etc…). Upon managing to close Zwift, I’m greeted with insane amounts of CPU usage, ramped up fans, and a super hot laptop. It makes absolutely no sense (and an almost drained battery despite being plugged into an outlet). I’ve tried restarting my computer which seems to solve the issue. Even weirder I’ve never had this issue before and I use Zwift on my laptop on a regular basis (multiple times per week)

I’ve always been running Zwift at 1080p/max performance as it’s plugged into an outlet and not running off of the battery. I never had this issue until this week. The attached pictures show what Activity Monitor was displaying during the initial ride.

After ending the first ride.
Before starting the second ride (post-restart)
And after the second ride, post restart


  • MacBook Pro 13-Inch 2017
  • MacOS Catalina 10.15.3
  • Zwift Game Version 1.0.48969
  • Zwift Launcher Version 1.0.23
  • Bluetooth connections: Stages Powermeter, Garmin HRM, wireless earbuds.
  • Charging cable plugged into wall outlet
  • USB Type-C to HDMI cable plugged into an old TV (TV plugged into a separate outlet)

Has anyone else had a similar issue/is this a known bug with Zwift. Or is it an Apple-related issue (not the first time I’ve had issues with my laptop).

No issues here on my mac. Do you have another cpu intensive game or app you can try? I reckon it might be your Mac. Tried bench marking it?

Tried both but with no luck replicating it sadly. Tried two games out (one CPU intensive, one GPU intensive) to see which it was. Nothing stood out as abnormal. Same with benchmarking, temps and clock speeds were all fine.

I’ve moved on to checking the ports to see if it’s maybe a power-delivery issue when plugged in.