Cannot connect zwift to mac using native BLE

After the last update I cannot pair my tacx Satori to the macbook directly the only way to do it is thru Companion app.
I use macbook air 2018 Mojave 10.14.3
I see the tacx trainer on my phone normally

my MacBook pro will pair but loses connection when i click “Ride” to get into the game - I’m using Mojave 10.14.3 - a couple of months ago i was using sierra Operation system and everything worked fine. If you get this resolved please let us know how you got it fix - Apple has been telling me for weeks that is not on their end. Wahoo says the same

I had a Zwift session yesterday using my MacBook Pro (Mojave 10.14.3) and native BLE.

Zwift picked up my Neo as well as my Viiiiva HRM bridged devices with no issues.

@Dino_Trojak @H_Harris_Handcycle
Have either of you tried removing the Bluetooth prefs file (/Library/Preferences/

Here is a more complete reference for you if you are not that familiar with OS X:


Wow thanks a lot @Lin_Alan this did the trick for me!