Zwift crashing? [April 1 2024]

Hey all, I have two mac (older ones). One, which my wife uses for Zwift (MacBook Pro 2017 running Big Sur) started crashing as soon as she attempts to start a free ride (we have tried several different routes - the same result for all).
There was no Zwift update that I saw and the MAC had been working yesterday (Sunday) when she did her last ride.

I then pulled out another Macbook (2015) which had been used for Zwift, but essentially sitting on the shelf for the last 12 months. Fired up Zwift, the recent update was applied and logged in. Went to start a free ride and the exact same thing.

I’ve tried both my profile and my wife’s profile, same outcome.,
I’ve manually removed Zwift from the 2017 laptop as per Zwift’s instructions and re-downloaded and re-installed, still same issue.

Has anyone experienced this and if so, was there anything you did to resolve it?
As mentioned, the 2017 Macbook had been running Zwift without problem up until yesterday.

1 Like

I ve got the same issue, MAC 2017 and MAC 2022, screen collapses after the blue screen shows loading track, it was working fine two days ago. No change in hardware.

1 Like

Bonjour
Je lance l’application sur Mac elle se lance, les appareils se connectent bien
Je souhaite lancer une session
Le chargement se lance et l’image bleu se lance
Et puis tout d’un coup l’application de coupe
J’ai déjà désinstallé l’application et re téléchargé

I’ve been using zwift for years on a late 2015 imac with no problems, including on the currently installed version of the OS. Current OS version is Monterey 12.6.?. No OS update for months.

31 March 2024 zwift worked perfectly.

1 April 2024 it doesn’t.

The program starts, eventually gets to the pairing screen, then when I get in to the game I select a world and route.

After clicking ‘start ride’ it goes through the process of loading the world and just after the ‘click’ sound the screen starts to change to enter the world and everything stops. The game window disappears and that is it.

I tried multiple times and restarted the system once.

As of today it is also having trouble seeing my paired sensors.

Mac is not my main computer, I use a PC with Linux, so I’m not fully familiar with trouble shooting.

I looked in documents for error logs. There are a lot of log files but nothing in the files from today look like errors.

I don’t know what to do about this.

1 Like

Yep, that’s exactly the issue I have. The 2017 was on Catalina… I tried upgrading it to Big Sur, same issue. And trying to roll back now to a completely fresh MAC OS build.

1 Like

A couple of other people appear to be having similar problems

2 Likes

Something must be up since there are now three recent threads about this issue.

I did a quick test on my 2021 MacBook Pro (current Sonoma OS) and could not replicate it.

@Oliver_ZRace_Central @Chris_D9 is it working for you?

2 Likes

Another report from Facebook

Same issue, fine on Sat now… crashes after loading the world, if I select just watch it works ok (few times) but clicking back to me…. Crashes
Re-installed… now credentials not remembered and a terminal window showing the processes… and still crashes

2 Likes

Makes me wonder if an April Fools Day feature flip went awry

Today the issue is back. Zwift at best

Same issue here, 2017 MacBook Pro, Ventura 13.6.6 Worked fine then today Nada!! I have logged a case with support.

1 Like

My system has been bugging me about an update for the OS for months so I just updated it. I figured it’s broken (I only use it for zwift) so why not?

New OS version is Monterey 12.7.4 but same problem.

1 Like

Exactly the same thing happened to me- even after rebooting, deleting and re-installing. :woman_facepalming:

I´m running MACOS Monterey 12.7.4, I remember that with former OS like Catalunia one had to give manually the permission to Zwift to access the folders in the security administration. I deleted Zwift, reinstalled, checked the Data access permission, but it still fails to run. Bluescreen loading track, at the end it turns orange and shuts down. Installed Zwift on my iPhone, it runs, but who wants to ride on Zwift with a iPhone :frowning:

April fools gone bad???

I’ve got the same issue. Worked fine on the previous Mac update then updated yesterday to monterey 12.7.4 on my 2016 MacBook and now Zwift crashes as soon as you go into a world.

Meanwhile I think that someone had a good idea and left for the weekend

1 Like

I doubt it would help, but since the only theory for the cause at the moment is the VR goggle April fools thing, can you at least get to your garage and remove any helmet/hat your avatar might have? Removing this supposedly removes the VR goggles.

Frustrated I gave it a try and permitted Zwift “full disk access”, something You don’t really want, but no change, it crashes.