Mac blank screen, colored screen and black blocks [October 2021] [1.18.0] [SOLVED]

Zwift no longer opens on my Mac Mini (late 2014) under MacOS X 10.11.6 after update. I click “Let’s Go” and the application crashes. Help!


Not working on my Mac. Software opens but the main screen is completely blank. SOS!


Same here. Even restarted my Mac. Even tried reinstalling the app. Still crashes.

1 Like

Likewise. Cannot open on Mac. Rebooted computer. Reinstalled app. Still won’t work


Hello @Rodrigo_Lanari and @K_Lohm welcome to Zwift forums.

Would you screenshot the blank screen and drop the image in your response? We’re looking at your server logs and it appears that you are reaching some menus? Would like to confirm where you are running into problems.

Hi… the same here. After the update I’m facing some issues. The screen is totally black and the resistance feeling is a little weird.

Running on a old Mac mini (late 2012) and MacOS Catalina (10.15.7)


My screen has the login, then it has a page about running with zwift, then another page tries to open & message comes up saying contact zwift support.

I have MacBook Pro (2017)

Running into same issue… App crashes when I click “Lets Go”


Thanks everyone for checking in on this thread. We are also seeing your issues in our telemetry data.

Moving forward on new reports: please report what version macOSX you are using.


Experiencing some glitchy graphics on OSx with this update!


Using macOS Sierra version 10.12.6. Similar error. Tries to open, showing running ad, then pop up stating Zwift will not open. Contact support.

1 Like

OS X El Capitan version 10.11.6
MacBook Air (not Pro)

1 Like

Graphics a mess on my Mac book after update. Randomly changing between colors and just a straight black screen. Running Mojave 10.14.6


This is exactly what I experienced after the update was installed on my old MacBook Pro. Running macOS Catalina 10.15.7 on dual core i7 with Intel HD Graphics 4000. The color changes on each new login. Looks like this issue is related to the integrated graphics on Macs.


Running smooth on Mac on my end. Running the latest version before monterey.


This is what appears on the third page after Let’s Go


Using MacOS 10.13.6 on iMac (12,1). Get the Let’s Go, then get the running ad, then nothing. No dialog or anything.


That screen indicates you’re on an outdated version of the Zwift launcher app, and that’s not helping any.

In your case - please follow these instructions to re-install Zwift to get you at least to parity with the latest launcher version. There’s a step to preserve your personal best and custom workout data too - don’t forget that.

Also - if you’re starting Zwift from an icon pinned to your dock - be sure that the icon is for ZwiftLauncher.exe and not for ZwiftApp.exe