Mac blank screen, colored screen and black blocks [October 2021] [1.18.0] [SOLVED]

Having same issues. Glitches and freezes/strobe effect - doesn’t work, can’t ride. Tried reinstalling Zwift, restarting computer, re-syncing bluetooth. Problem still persists. Running Mac OSX 10.15.7

All on this thread - we’ve been diagnosing root causes and are working on a patch to address these graphics issues. This is getting our highest priority. We’ll update this thread with more information tomorrow.

11 Likes

Catalina (10.15.7)

Here is the picture. it is totally blanked on the main screen. sometimes it appears but with weird colors. before todays update was working smoothly

2 Likes

Hi - can those who are having issues post what specific computer they are having? According to the posts so far it looks less about what version of macOS you have and more about what graphics processor is in your system. If you click on the Apple logo at the top left the info that would be interesting is:

  • Computer type (ie, MacBook Pro (15-inch 2016)
  • Processor (ie, 2.9 ghz Intel i7)
  • Graphics (ie, Intel UHD Graphics 620)
  • MacOS Version (doesnt hurt to have the info just incase!)

MacBook Air (Retina, 13-inch, 2020)
Processor 1.1 GHz Quad-Core Intel Core i5
Memory 8 GB
Graphics Intel Iris Plus Graphics 1536 MB

I’ve got the same thing here. You are not alone!

I’m seeing the same thing on my MacBook Pro. Click Let’s go and it crashes. Everything worked yesterday. Even tried reinstalling.

3 Likes

El Capitan 10.11.6
MacBook Pro (13-inch, Mid 2012)
Processor 2.5 GHz Intel Core i5
Memory 8 GB 1600 MHz-DDR3
Graphics Intel HD Graphics 4000 1536 MB

Instant crash after Let’s Go click.

1 Like

Same problem. app crashes after hitting “Let’s Go”.

MacOS High Sierra
10.13.6
iMac (27-inch mid 2011)
12 GB 1333 Mhz DDR3
Graphics AMD Radeon HD 6970M

From the Log.txt:
[21:41:16] Log Time: 21:41:16 2021-10-20
[21:41:16] Game Version: 1.0.85474
[21:41:16] Config: Shipping
[21:41:16] Device: iMac12,2
[21:41:16] Launcher Version : 1.0.25
[21:41:16] Loading WAD file ‘assets/global.wad’ with file.
[21:41:16] Loading WAD file ‘assets/Environment/Ground/textures.wad’ with file.
[21:41:16] Loading WAD file ‘assets/UI/WhiteOrangeTheme/WhiteOrangeTheme.wad’ with file.
[21:41:16] Loading WAD file ‘assets/UI/minimap/minimap.wad’ with file.
[21:41:16] Loading WAD file ‘assets/UI/WhiteOrangeTheme/Scotty/Scotty.wad’ with file.
[21:41:16] Loading WAD file ‘assets/UI/layouts/layouts.wad’ with file.
[21:41:16] Loading WAD file ‘assets/Environment/GrassTextures/GrassTextures.wad’ with file.
[21:41:17] Successful audio init!
[21:41:17] Loaded audio banks
[21:41:17] Initializing graphics window of size 0 x 0
[21:41:17] GFXDevice_Metal::Initialize(): Failed to find device
[21:41:17] Calculating Graphics Score

I see you think you’ve found a root cause, I hope this helps. I noticed everyone posting was on Intel internal graphics but the issue is not limited to Intel. I’ll see if I can boot into windows on this machine and try Zwift.

1 Like

Screen Shot 2021-10-20 at 11.23.30 PM

Same here on my 2009 Mac Pro with El Capitan 10.11.6
I did a complete uninstall and reinstall but mine also crashes or does nothing when I click “Let’s Go”. I read that in December 2021 I will require a newer OS but 10.11 is supposed to be enough right now.
2009 Mac Pro
2.66 GHz Quad-core Intel Xeon
ATI Radeon HD 5770
MacOS El Capitan 10.11.6

10.11.6 on a Mac Pro 2009

I’m on the same OS but on a Mac Pro 2009

I’m having issues as well


os

MacBook Pro (Retina, 13-inch, Early 2015)
Processor 2.9 GHz Intel Core i5
Graphics Intel Iris Graphics 6100 1536 MB
MacOS Sierra 10.12.6

Same issue. Have had zero issues in the past until I updated today. I get the opening screen post log in then it crashes when I go to “lets go” Tried full reinstall etc no joy. Running older macbook Air, OS Sierra 10.12.6. 1.6 GHz Intel Core i5
Intel HD Graphics 3000 384 MB

1 Like

Having the same issue. Once I select ride, it hangs in the blue screen then turns black.
||•|Computer type (ie, MacBook Pro (15-inch Retina Mid 2012)|
||•|Processor (ie, 2.3 ghz quad-core Intel i7)|
||•|Graphics (ie, Intel HD Graphics 4000 1536 MB)|
||•|MacOS Catalina 10.15.7 (latest)|