Zwift Crash "Apple" After screenshot [SOLVED]

Well this sucks; Zwift hard crashed about 9 miles into the Country to Coastal route. No record of the ride in Companion, on, or on Strava but there is an “in progress activity” and fit file in /Documents/Zwift/Activities. Running a fresh Zwift update on current Mac OS Monterey (12.6) and current Companion (no app store updates evident as of 11.09).


And another hard crash, this time on Island Hopper - Corollary for both this crash and the Country to Coastal were at the moment I took a screenshot with the camera button in Companion. Mac OS Monterey, latest Companion on current iOS. Looks like the (partial) ride FIT data is saved in /Activities but as far as I can tell there’s no way to ‘resume’ one of these rides either from Companion or the Mac desktop app.


Mac OS version 11.6.8
2017 MBP, Intel/Radeon Pro 560
Zwift game ver. 1.0.105825

Game crashes when taking a screenshot from companion - Just closes without warning. Please fix.


I too had a hard crash 15 km into the Turf N Surf route. However the companion app did manage to record the ride up to the crash.

I’m using an iMac (Retina 5K, 27-inch, Late 2014), running the latest version of Big Sur (11.7.1). Big Sur is the last version of macOS that is supported on this Mac.

One detail is that I was taking a photo with the Companion app immediately before it crashed.
BTW, this is the first time Zwift has crashed on me. I’ve been on Zwift (using this computer) for over a year.


I and at least one other I know crashed on Mac OS immediately after snapping a screenshot via the companion app (iOS). Oh and our ride files are corrupted too, so no good manually uploading them to Strava, etc.

Thanks @Christa.L for forcing us this buggy update on me which ruined not only my warm-up but ride plans! Good thing it wasn’t MY turn to lead our weekly group ride.

Just fix it please!!!

1 Like

WOW, happened to me as well, thx for reporting.

Hi zwift,

I have a bug to report. Not sure if others have experience today.

TOday i have downloaded the latest update. Let me firstly say i have not had a problem before downloading this.

During todays TTT, on the companion app, I take a picture, and then the game completly closes and i am back to my desktop screen. I was annoyed this happened as it was unexpected and during a workout.

So I open the game back up again, and try one of the new maps, 5KM in i decided to take a photo of the scenary and my avatar VIA the companion App, and to my surprise again, the game crashed.

So i am reporting because this happened in the space of 20 minutes and through the same method.

1 Like

Taking picture from companion app closes game on the new Makuri Island routes. I shut down two rides by taking a picture. Using appletv latest rev, iPhone latest rev and latest companion app

You restart game and it asks if you want to continue unfinished ride or something like that.


I re-updated CA. It still closes game now it does not ask to return to open activity it starts over.

1 Like

Similar issues here, on a MacBook Pro (13-inch, 2020) with an external GPU (AMD Radeon RX 580) and macOS Monterey 12.6.1.

I had multiple crashes yesterday in Urukazi, and even on the home screen, which has not happened previously.

I have recently noticed some pink “flashing” in certain places of Makuri, such as the approach to the Castle KOM and in a few places of Neokyo. I have no idea if this is related.

I uploaded the logs to Zwiftalizer, but there was nothing special to be seen there; the frame rate was fine, I got Ultra settings with 1440p resolution and the CPU load wasn’t too high either. It’s just that the Zwift app suddenly closes when I make a screenshot (not every time, but too often…).


Those activity fit files can be saved with a few steps; there’s a website called which has a “fix corrupt timestamp” tool, using this plus re-assigning an accurate date and time with their “time adjuster” I was able to manually upload the partial rides to Strava.


Adding some specifics to assist Zwift team’s debugging

Monterey 12.6
Macbook Pro 2016, tons of ram and ssd space

iOS 15.6.1
iPhone 13 Pro, 274gb available

Companion current as of 11.09*. Can’t get the app version as there is now a forced update… (* edit: App store dates this new update 3.41.1 as released 11.09, but I had checked before my Zwift session and it was definitely not in the app store at that time, for me anyway)

Crash did /not/ occur at first manual screenshot, I had taken a few others in course of the ride prior.

Game app on the mac crashed immediately after pressing the camera button in Companion.

Companion app returned to its initial “home” screen

No “resume ride” in Companion or in Mac game app after rebooting

Probably worth a separate thread (i haven’t looked to see if there is one), but I have noticed Neokyo consistently going epileptic for several months now so it’s not just you… Have managed to get some sweet screenshots. Likely unrelated to these recent Companion-app camera crashes tho.

Hi @Ryan_Hicks_RO

Shuji at Zwift HQ here. I see you’re using a MacBookPro13,3 (2016 Macbook Pro) running macOS 12.0. That’s a very old version of OS Monterey, and operating systems that far out of date cause weird random issues.

Would you check if your laptop can update to a newer version of the OS? If you continue to have crashes - please contact Support so we can provide one-on-one assistance for your laptop specifically by checking system crash logs on your laptop.


I’m on Monterey 12.6 (21G115) according to the About this Mac screen. Looks like there is a 12.6.1 dot release (from earlier today) I have not done, so will try that and hope for more stability.

Hey everyone,

I split off your comments into this dedicated thread. Sorry for the out-of-sequence sloppiness that caused.

We are investigating this crash as a high priority, and I’ll update this thread as we make progress.


Crash while merrily taking screenshots in Urukazi. Details:

  • Apple TV4k (2020 edition) running up to date TV-OS
  • Zwift ATV App and Android Companion current versions (using Companion for game control)
  • approx 20.7km into the “Makuri 40” route (high complexity cavern with scaffolding - attached screenshots below)
  • re-entered app, received an “activity in progress” dialog with option to continue it - re-crashed when selecting
  • second app restart, continue with activity dialog worked
  • back in ride where I left off EXCEPT: “Makuri 40” progress bar reset, despite having 20.7km on the trip meter
  • continued riding - and riding…and riding
  • fourth time around “Mangrove Maze North” - yeah, I think I’m stuck in a loop - I should be back at the start pens by now it auto-routing was working.

I’m here to sweat so I did a full 41km despite being sure I wouldn’t check off the Makuri 40 badge - fun ride regardless. I am curious if I’d ridden another 20km, would the game have given the badge, despite not being where I was supposed to be?

Pre-crash screenshot followed by post-crash resume - note the progress bars.

Resulted in two saved activities, map plot same but second one showing full distance.

Also: Hi @BooX and @James_Zwift !!! Nice seeing you guys, despite being trapped in the Mangrove Maze!


Great meeting you too Otto :grinning: Sorry to hear about the crash issue, but at least you got some miles in ( and a great excuse to purchase a gamer laptop :smirk: )