Zwift Crash "Apple" After screenshot [SOLVED]

Responding to myself, I’ve done a bit of debugging which might be interesting or useful for the developers @shooj :

  • If I hit the camera button while being in the main menu, it crashes every time. Every time. Maybe I should stop doing that… :wink:

  • If the app crashes while being in the main menu, when I restart the app and enter the pairing screen, it first shows it struggles with Bluetooth (some triangle above the BT symbol) and after a while this disappears.
    I manage to connect to the trainer, but it’s unable to use ANT+ (which is what I normally use for connecting). The trainer, cadence and HR monitor only shows up as BT in the pairing screen.
    After rebooting Zwift another time, however, I manage to connect the usual way through ANT+.


Having the same issue. MacOS Monterey 12.6 (is not “very old”!). Main crashes immediately when trying to take screenshot. Lost an hour ride.

:laughing: I have a quasi-gaming laptop! (Core i5-11300H, 16GB RAM, Nvidia RTX3050)

I think I’ll hook that up to the TV in my pain-cave for the remaining Urukazi rides, until we’re sure the bugs are worked out. :big_z:

Unrelated: +17°C here today (“normal” would be +6.3°C) and I got an actual outdoor ride in too - practically unheard of for November in Ottawa, Canada. It’s been a lot of riding today.

1 Like

Do the games automatic screenshots crash it, or just manually taking a screenshot crashes it?

Continuing my debugging:

  • Regardless of which route I choose and how far I ride, screenshot number 20 triggers the crash.
  • This coincides with the maximum numbers of screenshots Zwift has been able to show (historically). Whenever I’ve done 20 screenshots or more (manually or automatically), only the first 20 would be accessible when uploading the ride.

So, until this issue has been resolved, this workaround seems to work:

  • Never make screenshots in the main menu, only while riding.
  • Never do more than 19 screenshots. (remember to include a margin, for automatic screenshots on every banner…)

Nice detective work! :male_detective:

We noticed something similar and are tracing the code underlying that 20 screenshot issue.

Best suggestion at the moment for Zwift running on Apple OS platforms is don’t take manual screenshots using the Companion app.


This happened to me today during a group ride that I am back up lead for (Poursuite de la Lanterne Rouge). The ride starts at 7:00pm UTC. At 7:18, my system crashed although not precisely after a screenshot as I had taken several without incident. (Another rider had a system crash at the same time I did.) I was able to rejoin, then the rider leader also had a system crash about 7:28, unable to rejoin. The beacon fell on me, but of course no fence control. I DID take several screenshots after rejoining with no further crashes. Sure hope this is patched before next week’s ZRL races :grimacing:

Well look at that! Went to my camera roll and yep, it was screenshot #20 killed each of my rides too. (Don’t really need 20 screenshots that’s for sure but you know, new scenery and all…)

Question tho, I had this issue when running the /previous/ version of Companion as yesterday’s update wasn’t pushed through to my app store when I checked before my rides. Just to confirm, you all are on the latest Companion version (updated late yesterday/early-today-ish) and also having the crash?


Not the person you asked but I can confirm I was using the latest version of the Companion App when I crashed. (I updated before I started my Urukazi ride) I was so snap-happy I’m not surprised I ran into the 20 pic limit.

Kind of amazed we collectively (@anderfo specifically!) figured this one out so quickly.


I had three rides crash in Makuri.

However, for all 3 rides the 18th picture brought the system down. Poof! The iMac screen flashed red, then the desktop appeared.

Mac OS (Monterrey) & latest companion app.

1 Like

My first few crashes were with the previous Companion app (without an Urukazi map) and yesterday’s debugging was with the latest version. Same issues with both. So maybe the Companion app version isn’t the main issue.


Could be 20 if there were a couple of automatic screenshots as well…

1 Like

Good datapoint @CitronPink_H. I expect @anderfo is correct that it’s the total of automatic + manual.

At what interval does the Zwift app take automatic screenshots?

@CitronPink_H : the elapsed distance and time on your last manual screenshot, #18, might give us a clue.

Is this 20 screenshots in a single ride? Or will 20 screen shots since the last update trigger it to crash? I am doing a long badge quest this Sunday and will cry if I lose the ride. I never take manual screenshots FWIW.

in a single ride.

1 Like

My crash was caused by manual screenshot #1 for me, from the Companion app. Assuming that the auto screenshot (which I never use) didn’t take 19 screenshots in the 45 minutes preceding that. Riding on Urakazi now. Won’t dare touch the screenshot button. :confounded:

Rode for 90 minutes today on Makuri. Didn’t take any screenshots manually and no crashes. Don’t think it’s related to the quantity of screenshots or the auto screenshots.

Yep, latest version and crashed on 20th screenshot!

I believe there is one at 18 minutes 11 or 12 seconds and then one at each notable event, these include ending a workout, beating a PB and that kind of thing. So you’d need to go through a lot of sprints or climbs to hit the limit if you’re not snapping manual ones every few minutes.

1 Like

UPDATE November 11
We are still working on this bug, and it did not make it into the v1.31.1 patch for PC / Mac that went live a short time ago.

Please bookmark this thread for progress reports. Thanks for your patience.