Zwift Crash "Apple" After screenshot [SOLVED]

Zwift should at least be buying @anderfo a beer for pinpointing the trigger of the bug. I’m on a MacBook Pro (M1) running MacOS 13.0 with today’s Zwift client update. Replicated the bug using the Zwift Companion on iOS taking 20 screenshots.

Can we at least put out a warning as an announcement on the Zwift Companion to warn uses of this bug?

I hit the bug twice, each time with 2-3 km left of the route for Tour of Makuri stages. This is extremely frustrating and I wish I had known about it so I would not have wasted my time.


I rode EVO CC 160km Base Ride [2.5w-2.7/kg avg] on Makuri Islands Country to Coastal this morning. We got to 160km just after the Tidepool Sprint and I did an extra km to reach 161km. Then I stopped and took a screen shot with me and the three old cars parked by the beach and Zwift crashed. Funny after 4h10min! Panic for a couples of seconds but I started Zwift again and resumed the ride and it got saved and synced to Strava.

During the ride I took seven screen shots so the last one was number 8. None were saved to the ride. I always use Companion taking screen shots.


  • Iphone SE ver 2, IOS 15.7
  • Zwift ver 1.31.0 (105760)


  • Samsung A3 (2017), Android 8.0.0 (no roads in Urukazi)
  • Companion ver 3.38.0 (146) server ver 1.303.0

I have done the other Urukazi routes earlier this week and have taken screen shots without Zwift crashing.

There was a lot of automated screenshots on that ride. So you probably ended up over that infamous 20 screenshot threshold

Still don’t think it has anything to do with the quantity of screenshots. But I guess that’s just me. The crashes all seem triggered by manually taking a screenshot with the Companion app.

I mean, I rode for only 45 minutes and it crashed the first time I took a screenshot. I rode the next day for 90 minutes, no crash, didn’t try to screenshot. Then you have Maria above who rode for 4+ hours, no crash until she tried to take her first screenshot manually.

1 Like

Yes, it must be the automated screenshots. I just tested the 20-screenshots-bug and Zwift crashes every time. I am glad I didn´t take that 8th screenshot at 159,9km.

Same here. If I take a manual screenshot with Companion App within seconds of starting a ride, it crashes…every…single…time. 100% crash rate, regardless of World, course, group ride, workout, solo free ride, etc.

For me it has absolutely nothing to do with 20+ automated screenshots. That may be a separate bug.


Since it happens every time for you, it does seem to be a separate issue.

For me, it only happens after taking 20 screenshots in one ride (regardless of selected world). And it only happens if I use the companion app to take the screenshots. If I take screenshots with the desktop computer (F10), it simply stops taking screenshots after 20 (no crash).

My setup is a Mac running Zwift on macOS, and the companion app on an iPhone with iOS.


I’m seeing the opposite problem with the mac client. It no longer appears to take any automatic screenshots. I have only been riding Makuri routes since the latest client update. I started noticing that no screen shots are being taken during the rides as one would normally expect for badges, PRs and race results. Nothing is saved and nothing is uploaded to Strava.

Same here for me. No relation to the quantity of 20 screenshots. It simply crashes every single time I am taking the first manual screenshot via Companion App no matter any other circumstances.

Game client: 1.31.0 on macOS Ventura, Macbook Pro 13”
Companion App: 3.41.1 (1350) on iOS 16.0.2 (20A380), iPhone 11

Thank you for investigating and the transparency via this thread :slight_smile:


1 Like

I had a Zwift programme crash yesterday during an EVO Flux ride on the “Fina and Sandy” route. It was 23.2km into the hour long ride. I had taken several screenshots with the Companion App camera up until then. I went back into Zwift and was able to continue with the ‘unsaved route ride’, but as I had ‘technically’ not completed the Flux ride, it did not show on Zwift Power. Strava only accounted for the distance up until the crash, so I thought I would substitute it with a manual event input. However, I kept receiving Strava’s “Oops! There seems to be a problem” page. No resolution so far, and all this occurred since Zwift’s last update. Can I therefore suggest that Zwift make a general announcement to ALL users that you still have a problem? There are going to be some very annoyed riders if this happens during WTRL and ZRL events!!! I have already gone very public on this issue on my club’s FB and Discord pages. You really need to sort this out and stop fobbing us off with lame excuses!!

1 Like

Any idea on an ETR?


Same problems here on macbook m1 pro and iphone 11, all on latest OS. After some screenshots it crashes zwift. Looking forward to update.

Glad i found this thread.

Had a hard crash 2km from the finish line of WTRL TTT last Thursday while taking a screenshot of our team using the Companion app. Got completely logged out of Zwift (Apple TV 4k, Samsung Galaxy S21, everything up to date).

I just put it down to a glitch in the system, until taking a screenshot today, my first Zwift ride since Thursday and yet again had a hard crash.

Uninstalled and reinstalled the companion app, checked Apple TV for any new updates and still crashes.

I lost all the Zwift data on the WTRL ride, nothing showed up on ZwiftPower but my ride did save on Strava.

I’ve had two Zwift mechanicals during events. One was a race on Makuri Turf and Surf, the other in France on RGV. Both were within the last 5k of the race/ride. I don’t remember if taking a photo from the companion app triggered the crash although I was taking multiple photos as I was trying to document the race specifically (since I was riding so well).
Can’t wait to see the fix come through and thanks for figuring out the photo from companion app link. Guess I won’t be documenting my rides anymore …
Ps. Thanks for fixing the remove HUD error that caused the photo to go black!
IPad Pro 5th Gen, iOS16.1.1 latest Zwift
IPhone13 , iOS16.1.1 latest Zwift

Gang, we’re still working on this one. Don’t have an ETA on a patch fix yet, but I will update when we have news.


Hello - since the Uruzazi update, taking a screenshot on Apple TV will instantly cause it to crash. It doesn’t matter where in Apple TV (such as in the menus, during the game, etc…). I’ve tried it on two different Apple TV units, and both crash every time, instantly. These are on Apple TV 4K (non-2022), and triggering via iPhone 13 - all with the latest iOS and Apple TV versions. The Zwift app fully closes out, and when you go and re-open the app again, it’s back at the user-login screen.

It’s been doing this for the week since the update. Crashes don’t occur when using a PC or Mac, just on Apple TV. And as long as I don’t take a screenshot, no issues (and no issues when it automatically takes screenshots behind the scenes - those show up just fine).

Is anyone else seeing this?


1 Like

Can’t believe I’m about to do this to you but… known issue. :wink: Zwift Crash "Apple" After screenshot

It’s affecting a variety of Apple devices. There’s something amiss with screenshots generally on the latest update, same with all sorts of other issues.

Doh, I even looked in all the places, but totally missed it! Feel free to zap this one.

1 Like

Strange. I’m also on AppleTV and always take a screenshot of my stats after the ride. Works fine as always, no issues. Taking screenshots via CA on iPhone SE 2020, everything with latest updates.