Zwift Crash "Apple" After screenshot [SOLVED]

How do you turn off auto screenshots?

At the moment, there’s a bug that ignores image uploading preferences.

However, your can set your preference in your settings. If you’re using Zwift on a desktop, there’s an item called “Image Uploading” that you can set to “Only my shots”. Unfortunately, this setting is missing on the mobile version (at least on iPad).

Keep in mind that, at the moment, even if you set this setting to “Only my shots”, autogenerated screenshots are still taken due to the bug mentioned above.

Same for me using the new Apple TV 4k 2022. It crashes yesterday and today at Stage 5 of Tour of Makuri Islands short before finishing. Yesterday at The Long Ride after giving a Ride on, today at The Shorter Ride after taking a screenshot. :frowning: Before crashing I gave many Ride On`s and screenshots at these rides without problems.

By pure coincidence, I upgraded to a dedicated gaming PC for Zwift yesterday, and I can now take manual screenshots with the very same iOS Companion App that previously caused immediate crashes on all my Apple-Zwift devices.

Just yet another data point for the discussion.

strong text
I am doing the Maruri Island challenge. So far two stages have crashed on me about 80% into the ride. I am on an iPad with the latest software. After the crash it lets me log back on and continue the ride but at a lower level. I also don’t get credit for the ride but it does save as a Makuri Island ride. Looks like my xps weren’t updated correctly though.

My internet speed is 1.5Gigs and about 600K at the workout station.

Windows 10 user here. Zwift crashes taking automatic screenshots in events (Makuri, crossing banners) and when riding with friends (London, after a certain time). I just found broken jpgs in the picture folder with accroding times stamps.

Well, Zwift has become pretty much unusable for me since any screenshot (now even manuals) triggers the app to shut down. The longest I can ride in one go is 18 minutes, then the automatic screenshot will crash Zwift and leave me with a broken fit file. Most times, I will have passed a banner before that mark. Feeling like a (paying) beta tester :unamused:

I agree, it’s infuriating…as is going this long without a fix. I have automatic screenshot uploading disabled, which I have to hope means Zwift is no longer taking its own automatic screenshots, but I can’t confirm that.

As long as I don’t take a manual screenshot with my iOS Companion App, I can get through a ride normally. However, it is a feature I really miss. I used that feature quite a bit to capture things important to me. The keyboard shortcut isn’t as “agile,” but better than nothing until we see a fix.



  1. Launch Makuri on macOS
  2. Connect iPhone with Companion
  3. Make a photo in companion app

I get photo.

Zwift crashed.

Please remember that I pay for this. Please fix it ASAP. It’s hard to motivate to exercises and when I did that then I get crash twice, loosing my ride’s data.

And after this I see my activity in Companion as something in progress. Cannot continue, cannot save.


Apparently they have already coded a fix but they aren’t planning to ship a patch update, so it waits for the next release (1.32)

1 Like

Have you all checked if you have enough memory left? I just found out that the hard drive my Zwift screenshots are saved on was full (differs from the game installation). A short test was succesful (manual screenshot and automatic screenshot taken at banner), haven’t tried the automatic screenshot taken after a certain time yet. I will report on that later…

The automatic screenshot after a certain time did not cause Zwift to crash. So clearing space actually solved my problem.

That’s awesome, but not my issue for sure. I have a dedicated 1TB Mac Mini with literally nothing on it but Zwift.

Zwift crashed when taking screen shots/photos in companion. Apparently this is a known issue but I only found info from 2018 here. This has happened twice now. Once at the end of a ZRL race. I took a screenshot from companion of the results and the system completely crashed (black screen). Restarted and resumed the activity and saved. Info was in WTRL and ZP but the ride did not save in companion as a ZRL race it saved as a free ride. Then last night I was riding WTRL TTT taking pictures to distract myself from the pain of Titans Grove on a Buffalo bike. Crashed just before the KOM the 2nd time through at 33k. Resumed as before but was dropped on the general course and not back with my team. Course completion started over at the leadin but kms were correct. Finished the route and the full distance scheduled and saved. Ride saved at 43k as a free ride rather than TTT. No results in WTRl or ZP and my power numbers were way off for 20,10,5 minute (though average power was accurate). The ride also saved in companion as a free ride at 33km when the crash happened apparently. I am running zwift on Apple TV (not newest version but it is 4k). Running companion on iPhone 13.

Hi Shiji!
Thanks for all your help and advices.
I lost my ZRL ride on Tuesday, and I don’t know if I took 20 photos and I lost my today’s Zwift Fondo (December) when was missing 5 kms… what was really frustrating :cry::cry::cry::cry:
Please, correct this issue asap :sob::sob::sob:
Thanks once again…!

Seems like Zwift should at very least warn people to not to take screenshots from Apple devices. If I didn’t visit here occasionally, I would never have known. A simple banner warning when loading up Zwift or even a mass email.

Good news - as I noted upstream - fix for this is coming next week! Thanks all for your patience while you resisted taking screenshots with the Companion app.


Good to hear there’s an update shortly. I wish I had found this link earlier as I have bought a brand new router and reformatted my ATV in the hope it would sort things out. Alas, I was bumped out of Zfondo this morning after 26k…

UPDATE December 7
This bug’s been fixed in Zwift game version 1.32.0, which just released. Please update at your earliest convenience.