Zwift Click not connecting

They have tolerance issue (welcome China plastics) and thus the battery is not always contacting the electronics, especially when you click a button. If you put 2-3 layer of paper below the battery, it’s fine.

2 Likes

That worked in my case​:pray::+1:

I took the Battery out for a few seconds, restarted, reconnected and it worked perfectly… I hope it stays like this.

I have also the exact same issue like you with my brand new Zwift Hub One Click.
Zwift, Handy App and Firmware are up to date 27.10.2023.
Connected over Bluetooth no problem at all.

  • and -buttons are recognized in ERG Mode to % change.
    But there’s no gearing shown in the left corner under the current Power.
    I want to ride races and shift my gears.

Please Help :disappointed_relieved:





1 Like

After a long night of troubleshooting and reinstalling all apps and drivers i found the problem.
I just removed the bluetooth connection in windows from the Click and the hub, now i can finaly shift gears in zwift.

hello

I still have a problem to pair zwift click with zwift windows app :

I see connected zwift play and zwift click in companion and firmwares are up to date for both.

my zwift play are good connected in zwift windows app but impossible to see the zwift click for pairing in the control pannel (bluetooth or ant+), same thing with the telephone mode.

I even tried with the android app, same thing, impossible to pair the click with bluetooth connection.

And it’s the same issue with the last 1.51 update…

any ideas ?

Never pair any fitness device used by Zwift in the Windows control panel. That will break Zwift.

I’m not in the windows control pannel but in the zwift setup pannel where you can connect devices

1 Like

I have also been unable to pair my Zwift Click with the Zwift app running on Windows 10. I have, however, been able to use my iPhone and Zwift Companion as a bridge between the Hub/Click and the Zwift App. I had opened a ticket with Zwift support about the Click/Windows connection issue and they made a few suggestions, but nothing worked. Once I told them I could get around the problem by using the Companion, they closed the ticket. Useless…Hopefully, they’ll figure out the problem if enough people complain.

My zwift click wont connect either. I (eventually) managed to connect the Play controllers and Click via the companion app and update the firmware to all 3 and thr hub but Zwift (running on windows 11 pc, with hub connected in bluetooth mode) just doesnt see the click. The controllers work left and right, but dont change the gear.

I’ll try again tomorrow, then ask for a refund if it doesnt work :rage:

I just received my new zwift hub. all gears are working but zwift click doesnt with zwif but only with zwift companion app.
Im using android with samsung galaxy 10. please help. all firmwares are updated.
[SOLVED]
solved, Ive
1.uninstalled zwift companion (zc) and reinstalled it, the thing we do not have to do is to pair ZWIFT HUB IN BLUETOOTH.
2. opened zwift companion and updated the Hub firmware first of all
3. updated zwift clic firmware
4. exit from zc
5. downloaded zwift app
6. opened it and everything was paired
Works very well with my polar h9 and h10 too.

The same for me here, just received my Hub yesterday. It works on my iphone. after 2hours, i don’t know how, the click has worked on my macbook, but after that, nothing. ive tried to pair it again, with bluetooth, with phone connexion, nothing to do. I can not believe that you sell a product without a good software… first experience for me with a home trainer and Swift, Shame on you swift

Well I’ll add one more to the list. Got my swift trainer a couple of days ago. Very intermittent and frustrating link to click. Sometimes connects to Mac. Often doesn’t. Sometimes connects, changes five gears randomly and drops out. Sadly it renders the entire purchase pointless unless I want to pootle about in 12th. Swift support is awful.

In fairness swift have been in touch by email but it’s made no difference.

If you haven’t already, try pairing via the Companion app and see if that’s more stable.

I have same issue. 1.5 week in and loving Zwift so far, but resistance on climbs is killing my knees. AppleTV 4th gen and iphone13 for companion app. I’ve ridden 100 miles and 1 race before realizing all of it was done in 12th gear because click controls weren’t actually doing anything. I’ll try all the suggestions mentioned here before I call support.

Update: resolved after forgetting click controls in companion app. unplugging Zwift hub. Restarting Bluetooth on phone. Re Pairing click controls on companion app. Plugging in Zwift hub. After doing that click controls are recognized and function in game.

The app can’t ‘see’ the click.

1 Like

I received Hub One recently and Zwift click did not work on Windows 11.
It did connect per application initial set up process but then in the game, it was not showing any gears nor responding to clicking unless in ERG mode, in which case it worked. Strangely enough, it was fully operational and working on Mac Mini right away.

I eventually found a solution and made it work in Windows 11 too.

The solution was trivial:
I clicked on my icon in the upper right corner, then went to My Settings / Preferences, scrolled down to the bottom and changed “Virtual Shifting” setting from off to on, as shown below.

If I made this post redundant, I apologize.

I went on zwift the other night and the click button must of disconnected about 5 times to the point of i was stuck in 13th gear going up box hill i only have the click and play controllers connected with tablet

This same issue has been widely reported on other threads. Unfortunately after being told many times by zwift support that they would “forward my question to the relevant team” and waiting for up to 10 days for replies that lead nowhere, I still have no solution I can offer you.

I hope it starts working for you soon but wouldn’t hold too much hope. If it is a recent purchase you may wish to do what I did and look into your consumer protection rights and see if you can claim a refund as the item is not as described. Even if the next patch fixes it, the trend on here is that every patch will cause a new issue.

1 Like

That’s annoying, just received my Hub One, and experiencing the Zwift Click dropping out after a few seconds on the gears, although it still lets you change the ERG mode which is weird! Windows 10 with new ANT+ and BT dongles, although everything seems to default to Bluetooth.

Will have a play around with it, but bit disappointed to say the least, as the Hub One was just what I was waiting for in a trainer. :frowning: