Zwift can not control Magene T300

I discover that Zwift can not control the loading of Magene T300 recently. Anyone knows the reason?

Thanks.

you need to use ANT+ to control the Magene T300 loading

I have the same problem. Zwift Android does not control the resistance over bluetooth. It works with other apps like the Magene Utility, which lets you test according to gradient or erg mode at a set power.

I had this same problem previously with another model of smart trainer, which was fixed after the maker updated the firmware on the trainer. I do hope this is a problem with the firmware on the trainer which will be fixed in the same way, but until that happens, ant+ for now.

Are you using android and ant+ for the magene? I want to buy a neo but all.stocks sold out in ph, we only have the magene t300 but not sure if its reliable and durable?

Will be testing Android with ant+ tonight. Update after trying it.

Much better if you can upload video on youtube, thanks

Got a firmware update today for the T300. Like magic, resistance is now controlled over Bluetooth for Zwift Android. No need to test the ant+ now, as I do prefer Bluetooth. Much more stable for me

Nice… for me i prefer ant+ as it consumes less power

Tested out 3 devices I have, using a USB C to USB 3 dongle and an ant+ stick. Installed the ant+ USB service, ant+ radio service and ant+ plugin service from google play. The ant+ apps keep reminding me that they are designed for older versions of Android and may not work with my devices. All my devices have Android 9. Ant+ USB service keeps giving me error that some kind of component is not found. Zwift Android recognizes that ant+ is available but can’t find devices. Maybe need to use devices with older versions of Android or built in ant+, I don’t know. No joy for me, but I’ve found some posts in the forum that say they managed to get their devices to work. Sorry.

Ant+ does not work on android 9, im using android 8 now, my friends told me they used android 10 and it worked with ant+ but i havn’t seen it

Is this still an issue???

No issues anymore

在 2020年8月6日 週四 17:29,Janet via Zwift Forums <gozwift@discoursemail.com> 寫道:

So what is the solution? Still not working for me. My configuration is Zwift on Android 10. ant+ works fine for T300 as power meter and cadence, but controllable just cannot find the T300 both over bluetooth or ant+. Using latest trainer firmware (something like v0.1.0.6)

Last night I spent hours trying everything to make it work to no avail. The device was just not found as controllable. I gave up.

This morning I tried once again just to make a screenshot to be sent to the seller, and it worked! It was detected as controllable bluetooth. First I searched for the power, both BT and ant+ appeared. I selected BT. Then I detected controllables, and it’s there, as BT. I don’t think I changed anything overnight. Weird.

Hi Benny may I know the setup you are using? I am experiencing the same problem.

Hi Emma,

My setup:

  • Magene Utility (downloaded the apk from magene website). The utility then updated itself upon first use
  • T300, updated to the latest firmware (v106) by the utility
  • Zwift on Samsung phones (both Android 8 and 10 work now. Previously both didn’t)
  • Bluetooth and location turned ON
  • Bluetooth is used to connect to both power and controllable sensors
1 Like

Hi Benny thanls for the reply! Unfortunately, everything that needs to be done checks out but still my T300 can’t be detected as controllable but only as powermeter amd cadence.:thinking::thinking::thinking:

Hi Emma, not sure if these would help, but these are also other things that I did:

  • reinstalled Zwift. Not so much to get the latest version, but rather to restore the permissions that I might have suppressed (I have a habit for that)
  • restart a nearby Wi-Fi router while T300 is ON. The idea is to let the router select wi-fi channel with least interference.
  • made sure no other devices (phones, computers, bike computer, sport watches) are attempting to connect to the T300

But as I said, even these didn’t work right away. It only worked the next morning. Weird.

Hi Benny got it to work connected it first as a power source and it showed up as controllable trainer. Tried it all over again and it worked through that process.

Thanks for the help! Keep safe!

Hola a todos, yo compré un T300, finalmente me funcionó controlable cuando descarge Magene utility, me inscribí, nombre, usuario y luego recibí un correo con un código de activación, recién ahí pude entrenar con ZWIFT. Pero necesito ayuda, no me toma la cadencia y tengo ANT+ Y BLuetooth. ¿Qué ocurrirá?