No resistance changes from zwift

I am new to Zwift and trying to get it to work. I am finding it is not controlling resistance or making any changes at all to resistance on my trainer with grade or ERG mode. I’m a software engineer and have gone through every conceivable test and read the forums and can’t find a solution. I need help !

Here’s the details of my setup:

  • PC running Win10, fresh install and not much else on the computer.
  • Zwift version 1.0.58982
  • Android companion app version 3.19.1 (should be the latest, was just installed)
  • Located in Colorado, USA. Great internet connection at the bike setup
  • Trainer is a Wahoo Kickr Snap
  • Connecting to trainer, HRM, and Cadence via ANT+ dongle. Though I get the exact same results when connected through BT via the Companion App

I’ve confirmed the Kickr works fine as I can run a profile with my Garmin Edge 530 controlling the Kickr and it changes resistance with grade as expected. Resistance also works properly with the Wahoo app on my Android phone.

As noted above, when in a free ride or group ride I get no resistance changes when the road grade changes. When running a workout, ERG mode is supposedly on but it is not doing anything. As I change cadence or bike gear, the power output changes commensurate with my changes, there is no resistance change to hold the power as ERG mode should do. If I stop pedaling, Zwift will notify that it is temporarily suspending ERG mode as it should to avoid the dreaded death spiral, but in reality nothing changes on the trainer. When I spin back up, Zwift advises it’s restarting ERG mode, but nothing changes.

If change the Incline in the Companion App during a workout I feel no change though the App shows that I’m changing it.

I get the same behavior whether the Companion App is involved or not. Also whether connected via ANT+ (with or without Companion running) or via BT through the Companion.

I tried to attach images to show the configuration and operation but the forum would not let me. I’ve dropped them in Google Drive but it would not let me include a URL so I’ve written out the start here ( drive dot google dot com/drive/folders/1ZGHuPXJZQDMmAFq4HNHI53_KGP90d5CE?usp=sharing ) that hopefully you can see. The images include:

  • My pairing via ANT+
  • My Settings
  • A capture of starting a Workout showing ERG is on
  • A capture of the screen in a workout where you can see the power is well below target, yet ERG is not doing anything on the trainer like one would expect to bring the wattage up with the slower pedalling, yet ERG is still engaged at 143 watts
  • A screen capture of the Android Companion showing ERG On

As a side question, I can’t find any way to talk with anyone at Zwift for support. Is there Zwift support or is the only support through the forums?

Thanks for any help you can offer !!!

Do you have your trainer paired not only as the Power Source, but also as Controllable?

Yes. I wish the forum would let me embed the images that I put on Google Drive. It shows that it is paired as controllable also.

How about running Zwift on your phone just to see how it behaves on a different platform. No need for the companion app to be running.

What jumps out at me is distance and therefore possible interference or weak signal. It works fine with the 530 and Wahoo app both located at the trainer most likely. It doesn’t work with the computer that isn’t located as close to the trainer. Is the Ant+ dongle on an extension cord? If not, it needs to be as close to the trainer as possible. I am not a Windows guy but I have seen people describe the bluetooth on Windows as a “dumpster fire.”

If you don’t have an extension for the Ant+ I would try and locate the computer right next to the trainer and see if that makes a difference.

Thanks Bob and David for the suggestions. Both great ideas to try. Here’s the results:

Android phone (Samsung Galaxy s10e):

  • ERG mode actually worked, that was nice to see
  • Resistance changes for road slope did not work. -3% and +7% had no change in smart trainer resistance
  • Good test, though the phone would not be a viable long term solution if it did work as I have the PC connected to my TV to have a large display. But at least as a test it gave some info but still not fully functional

PC:

  • It is a laptop on a music stand next to the bike with (and without as a test) an HDMI cable to the TV so it is only about 5 linear feet from the Wahoo Kickr Snap.
  • I put the ANT+ dongle onto a USB extension cable and moved the laptop behind the bike saddle so the USB dongle was only a few inches from the Kickr. No change in function. ERG and resistance on hills did not work
  • I installed Zwift onto a newer high powered laptop from another manufacturer (first was HP, 2nd is Dell). No change, not working :frowning:
  • I saw in ZwiftInsider the suggestion of moving Wifi away from channels 9-12. I moved my Wifi to channel 3 and that did not change anything either.

I’m still stymied as to what is wrong and how to fix it. Any other suggestions from the experience of the forum?

Thanks !!!

Just to be sure - did you check your trainer difficulty in Zwift settings?

Yes, a good question. It started out in the middle. I’ve turned it all the way up to Max witht no change.

I don’t think it’s WiFi related. Something to do with trainer/Zwift/platform communication. Can you calibrate your trainer using the Wahoo App?
I assume your phone test was using Bluetooth?

It’s acting like a dumb trainer so double check that Zwift is selecting the correct trainer and make sure your trainer software is up to date.

Yes, I can calibrate successfully with the Wahoo app. Attempts to calibrate using Zwift fail. Zwift seems to leave the resistance higher on the trainer such that I have to crank hard to get to 23 MPH then it spins down much faster than with the Yahoo app. Zwift then says the calibration failed.

The phone’s connection to all 3 devices was ANT+ not BT when I ran that test

Are any of the other devices still paired with the Snap? Every app you open must be forced quit after use and trainers should be unplugged as well. We went through a rodeo in my pain cave when my wife started Zwifting. Her phone would be paired to the trainer and I couldn’t figure out why I couldn’t get paired. She would open up Zwift while I was riding and I got dropped.

I just found Zwiftalizer and reviewed my log file. There were no ANT+ dropouts so that is not the culprit either

David, yes, all other devices are offline. The only other ANT+ device is the Garmin Edge 530 and it is turned off. For each test I even unplug the trainer for 30 seconds or so to ensure it is disconnected from whatever the last test was and start fresh.

Your making it tough on us. :grin:

Does sim mode work on Zwift? Can you pick a route in Watopia and have the gradients provide the proper resistance? The Hilly Route in Watopia should answer this in a couple of kilometers.

Are you choosing the FE-C device when you pair the controllable device?

Jep.

Just uploaded his picture.
Don’t know what’s wrong here.

Try if you can pair your cadence also via FE-C.
Shouldn’t make a difference, but looks nicer.

Is it right that the power source is FE-C and not just the regular one? I have no idea since I use BT and never ANT+.

The Power source should make no difference ANT+ <-> ANT+ FE-C, it only transmitts power data from the trainer to the zwift client.
The controllable must be FE-C, otherwise zwift can’t control the trainer. At least with my Elite Direto X.

You could try connecting everything via Bluetooth.

1 Like

Try the phone test again but use BT for all connections.
Also try Bkool or RGT or another game and see if the resistance changes.
Is this a new problem for you? Could your trainer’s control board have failed in some way to not allow comms?