Zwift app not detecting Tacx Genius as controlable

I am using a brand new Tacx Genius model 2080 (which I have already checked and is running the latest firmware).

The Ipad app will detect the trainer as a power source but will not detect the trainer as “controllable”. All it does is show nothing in that menu while searching.

I have tried the following…

~ Restarting the app (didn’t help)
~ Restarting the Ipad and the App (didn’t help)
~ Restarting the Ipad, the Genius and the App (didn’t help)

The whole reason I bought a smart trainer was for the variable resistance controlled by these apps so if this isn’t working then the whole thing is kind of pointless.

Hi @Leo_Monaghan

Did you test the controllable feature in the Tacx app?

Unpair everything from zwift, start pedaling and try to connect only the controllable box.


I have aligned, calibrated and tested the trainer in the Tacx app.

The Tacx app can control the resistance, your app still cannot find the Genius as a controllable device.

All of this is over Bluetooth via the Ipad.

I’m still having this problem.

Connecting via Ipad over Bluetooth shows power source and cadence but never finds the controllable device.

Tacx own software ~does~ find and utilize all three.

If I use your app for my windows laptop, it can also find the controllable device via Bluetooth (so I know that the Genius is sending out the signal for the controllable aspect) however using my laptop with the trainer is not what I had intended to do. I want to use my Ipad with this system.

So even with only connecting the controllable connection Zwift don’t see it. I was thinking to many Bluetooth connections.

Yes, if I unpair everything else, it still never finds the controllable device.

Also, I have also tried it with my laptop off and my phone set to airplane mode so there are absolutely no other devices attempting to connect to the trainer via Bluetooth.

I have the same problem with Tacx Genius Smart and the Android app.

1 Like

Same symptoms with my Tacx Genius and iOS / Bluetooth. Any solution?

Did you find a solution? I have the same problem!

Me too.

Is there any solution for this?

Best regards

I have this problem in the connections to the my genius powerback

I have exactly the same problem with the Tacx genius powerback, and I also tried all the same suggestions as guys suggested. I also tried the Ant plus dongle, I however read on a different forum that the ant dongle version 1 wont work, but Bluetooth should, it also doesnt

Facing the same problem. Is there any solution?

I’m facing the same problem as well, and use some sort of workaround to connect the Tacx Genius smart trainer as a controllable device over bluetooth.
When I first try to connect the trainer as a controllable device, it does not appear in the list. However, if I first search for and connect the trainer as device for cadence and/or power meter, and then search for the controllable device, it appears in the device list. Once connected, I can switch back to my device for cadence and power meter afterwards (I use Garmin Vector 3 as source for powermeter and cadense).
This must be done every time I connect my trainer as controllable device.

I also have the same issue. Is there a way this can be flagged to Zwift?