iPad Pro not getting full control connection with Tacx Genius Smart Trainer

So I have recently bought an iPad Pro and today went to connect it to Zwift for the first time. I have a Tacx Genius smart trainer that I bought last September. When the app loaded and got to the connect screen it recognised the power meter and the cadence sensor but not the full controllable feature.

Made sure I had all other apps closed on the iPad and all other devices in the house had bluetooth turned off.

Tried it on my MacBook with an Ant+ dongle and it all connects fine.

Any advice would be much appreciated

Try to turn off bluetooth on your phone before you attempt to connect the iPad.  My bluetooth heart rate wouldn’t show up on my iPad Pro and it turn out it was because I was used it early in the week with my phone and my phone had connected to it before the iPad did.  As soon as I turned off iPhone bluetooth it showed up for the iPad.

Strange that 2 of 3 show up.

Also…Try to completely power off the iPad and power it back up.

Good luck.

I’m having the exact same problem with my Tacx Genius–power and cadence meters both show up, but not the full controllable feature.  I’ve also tried disconnecting from all other bluetoth devices, and nothing works so far.  Any fix available?  



I found an answer that fixed the issue for me!  Try following the steps here to update your firmware on the trainer: https://support.zwift.com/hc/en-us/articles/205107765?input_string=tacx