Windows "N" Edition can't launch Zwift [May 2023] [1.39]

Hi there,
I opened my zwift this week, after about a month of not using it, and it updated automatically (of course!) but the newest update will not load for me

Initial installation worked. And I got to the opening screen. But when I clicked the “Let’s go” button, I got an error message to say

I got a popup system error saying “the code execution cannot proceed
because MFPlat.DLL was not found. Reinstalling the program may fix
this problem”

I hit OK

And I got another popup:
“The code execution cannot proceed because MFReadWrite.dll was not
found. Reinstalling the program may fix this problem”

I downloaded both DLL files from a trusted source on the internet and saved them into the relevant folders? And did a restart/re-install etc

Now I’m getting a new error message, which says: The application was unable to start correctly (0xc000007b)

I’m out of ideas at this point. Any help or guidance would be appreciated


Are you using an “N” edition of Windows? I’ve seen someone else report this after the latest update and I believe this fixed it for them. Note this relates to a different game but it’s the same error and the other user I saw referenced (on Facebook) was for Zwift as well.

1 Like

Suggestions from Arend did’t work to my regret. Did update, but nope, still no Zwift today

I guess the other option is to create the media for standard (international) Windows 10 or 11 and reinstall.

Cannot Zwift today. Missing mfreadwrite.dll file. Suggestion is to re-install Zwift. I did but it didn’t help. Seem to be something with Windows 10 pro N. What can I do? Will there come a solution from Zwift or do I have to fix it myself?

There’s a tip linked here

Hi @Wim_van_Uden welcome to Zwift forums.

The N edition of Windows strips out Media Player and other multimedia features built in to other versions of Windows. This might be why you’re seeing an error message about missing DLL files.

You can tell which edition / license is installed using this Microsoft support page.

Once you know which Windows update version is installed, try installing the right Media Feature Pack. The one for Win10 Update 1607 is here, and other update versions of Windows 10 and 11 are here.

Would you try those steps and tell us if that solved your issue? It may help others in the future with similar symptoms.


Thank you very much Shuji! Your link brought me the right Media Feature Pack. Restart and YES, Zwift is working again. I am glad. Thanks again



Thank you very much for trying the workaround and coming back to let everyone know it works. We appreciate you!

Thanks all for reporting this; we are releasing a fix in the next game release which will no longer require the workaround.


Hi everyone, this issue is solved with game release v 1.40 which began phased rollout today. Over the following two days, it should be available to everyone. Please update at your earliest convenience.

1 Like