Launcher 1.1.5 doesn't work in Win 10 (ntdll.dll)

After 2 years of zwifting without issues on my laptop, it is a Dell Latitude that I use for work at home not with super high specs but enough to load the game perfectly. Yesterday, I upgraded to new game version and launcher (1.1.5) and game is not loading anymore (zwiftapp.exe), I tried several things: clear MSEdge cache, disable firewall on all networks, installing updates, reboot n-times, and nothing worked.

I reviewed the event viewer and notice the issue, some dll is failing with zwiftapp.exe:

Faulting application name: ZwiftApp.exe, version:, time stamp: 0x63c9fbdc
Faulting module name: ntdll.dll, version: 10.0.19041.2130, time stamp: 0xb5ced1c6

I also tried some commands to “repair” issues on windows:
sfc /scannow
but also not worked, I’m out of ideas, yesterday I could not trained with zwift :frowning:

A new fresh installation of windows or something similar is out of question, this laptop as I mentioned is primarily for work

Hi @Emilio_Ocon

Welcome to the forum

Can you describe this a bit more.

Did you try to uninstall Zwift.

If it is a work laptop do you know if you have access to install programs?

Hi Gerrie

Yes, I did a “repair” installation, also a uninstall, clear contents of folders, and install again… without luck

Yes, I have admin right permissions on this laptop, some software is banned but not zwift actually it has been run perfectly for past 2 yrs

Same as mine. PC window 10.

I have the same issue, Zwift will crash just after i have logged in and when i check in EventViewer it also shows the ntdll.dll error, only difference is I am on Windows 11.

Check AV. mine is Anti Virus problem. AVAST killed zwift. turn off real time for a while.

Thanks Matthew, I already put a case with zwift support expecting some response today; I loop you here

I’m having the same issue. Downloadedv and updated the new release - Z117 patcher error line 602 (Standard for me and updates). Run Zwift launcher as Administer and forced to download new launcher. Run Zwift great until login screen where it crashes and shuts down.

Currently doing a fresh install

Windows 10 Acer Aspire E15 laptop Intel Core i3 processor, 8Gb RAM, plenty of HDD space

I’m having the same issue and the same error. It worked until two days ago Also I’ve just renewed subscription. I’ve followed instructions, but I haven’t solved the problem.
My pc ASUS is a windows 10 64 bit!

This workaround might help?

Same here, Windows 10 64bit - all worked fine until the most recent update.
Now Zwift won’t launch

The logs don’t really help me much

[11:25:14 2023-01-30] Launcher: Checking for VerCur Override
[11:25:14 2023-01-30] Launcher: prefs.xml file not found.
[11:25:14 2023-01-30] Launcher: Auto Startup is Enabled.
[11:25:14 2023-01-30] Launcher: Launcher Version Number 1.1.5
[11:25:14 2023-01-30] Launcher: Initializing UI Components
[11:25:14 2023-01-30] Launcher: Initializing Tray Components
[11:25:14 2023-01-30] Launcher: Initializing Patcher
[11:25:15 2023-01-30] Launcher: Setting Login URL
[11:25:15 2023-01-30] Launcher: prefs.xml file not found.
[11:25:16 2023-01-30] Launcher: Found Launcher URL.
[11:25:16 2023-01-30] Launcher: prefs.xml file not found.
[11:25:16 2023-01-30] Launcher: Navigating to Login URL
[11:25:16 2023-01-30] Launcher: Starting WebView2 Initialization
[11:25:16 2023-01-30] Launcher: Displaying Main Window.

I have exactly the same issue, and know others who also have the same issue. This is the Windows 10 event log:
Faulting application name: ZwiftApp.exe, version:, time stamp: 0x63d337cf

Faulting module name: ntdll.dll, version: 10.0.19041.2130, time stamp: 0xb5ced1c6

Exception code: 0xc0000005

Fault offset: 0x0000000000063526

Faulting process id: 0x9830

Faulting application start time: 0x01d934342484f7e2

Faulting application path: C:\Program Files (x86)\Zwift\ZwiftApp.exe

Faulting module path: C:\windows\SYSTEM32\ntdll.dll

1 Like

Hmm just looking through my event logs, it seems that KERNELBASE.dll is the faulting module…

I bet this and NTDLL aren’t the only ones the more I speak to people

Hi Guys

Finally, I solved the problem!!! after several trial and error; I kept searching over the web and see on some forums that a ntdll.dll problem might be due installation of Citrix Workspace app, it is replacing this dll or is messing with the graphic drivers, the latest version somehow is not working fine with latest Windows updates, that was my case; once I de-installed citrix workspace app and other plug-in related, zwift now run again.

I’ll try now with another version of citrix, some users has been deprecated the installer from citrix website and use windows app from microsoft store instead; I’ll keep trying until see what version of citrix could run along with zwift.


Hi, I have had this same problem on windows 10 pc and solved it with updating intel’s drivers in intel’s app

Hi Hidai

Thanks. I’ve already tried same solution, but it did not worked for my case, except that I blocked windows update for drivers because it detect them and use Windows repository as primary option for drivers even if Intel drivers are an upper version. I used Intel Driver support assistant and leave that working on my laptop

I’ve removed Citrix Workspace and Citrix Files but I still have the problem. Did you do anything else?

After I did the intel download and restart i reinstalled zwift with latest update and works likes charm

It can’t be Intel drivers. My laptop is all AMD (CPU & GPU) and the drivers are up to date.

I have 2 win 10 laptops, 1 HP with AMD CPU & GPU and a DELL with Intel CPU and NVIDIA GPU. Both have the ntdll.dll fault.