Why I am Too slow

I am new to Zwift and just got my satori Tacx. However when I use Zwift I look too slow on the screen. I am not sure if it does read my speed or not ?
I needed about 20 Minute to complete 1 Km which is can not be true.
I use 27 inch wheel and my wight is correct

Hi @Ahmed_Alghamdi

Welcome to the Zwift Forum,

We will need a bit more information like what do you use for Zwift, Pc of telephone? how did you pair your trainer? ANT+ or Bluetooth a screen shot of the paring screen will help.

Check this out.

Also check that your wheel is not slipping.

1 Like

Thank you Gerrie for the quick response
I use Zwift on iPad connected through Bluetooth.
Unfortunately I don’t have a screen shot right now but can be provided by tomorrow :+1:

Hi @Ahmed_Alghamdi welcome to Zwift Forums.
Shuji at ZwiftHQ here. From my end, it looks like you’re connecting a Tacx Satori Smart wheel-on trainer, is that correct?

The Satori may be connecting as your Power source and not a Speed source. Would you try connecting as a Speed source instead? That should get your speed data working as it should.

This is what I get

Ok so when I search for speed sensor this what I get

And when I search for Power source this what I get

I think power source is the way to go. Try that, take note of your power number while riding, or take a picture when you get up to top speed

1 Like

@Gerrie_Delport is correct, you should pair the Satori as a power source since it is a Smart Trainer (just broadcast watts). Make sure you use the Tacx app to calibrate the trainer and to see if there are any firmware updates.

BTW, I have used a Satori and the watts are fairly accurate.

1 Like

@Paul_Allen @Gerrie_Delport
Thank you guys
Here are two photo one form Tacx App and one form Zwift App.
I am giving almost the same effort on two of them

Issue remain the same I look to slow on Zwift App.

Hi @Ahmed_Alghamdi

In the Tacx app you are going downhill that is why it is faster than Zwift. In the zwift picture you are going up hill at 25w that is why you are going slow.

I am concerned that you are doing 100rpm and only 25w that does not seem right. What bike do you have on the trainer and what gear are you using.

1 Like

I am using Sunpeed bike with 27 inch wheel

Do you have a trainer tire and are the trainer roller tight against the wheel.

Size of the wheel makes little difference with a smart trainer.

Have you calibrated the trainer using the Tacx App?

In both images you are going similar watts, but in the Tacx app you are going down an incline and in Zwift you are going up.

Since this is needed in this thread I am going to post it:

With the watts broadcast from your trainer, the weight entered, height entered, in-game bike used, in-game drafting (Tri and TT bikes get no drafting boost), in-game wheel set, in-game road surface, and in-game virtual elevation changes your in-game speed is determined.

1 Like

@Ahmed_Alghamdi What resistance setting do you have the trainer set to? Zwift should have a recommended resistance setting for this trainer I think? Perhaps it is set at 1, and should be at 5?

This is from the Tacx website: The Satori Smart is the only manually controlled trainer which measures speed, power and cadence. The resistance of this wheel-on trainer is changed manually with 10 handlebar positions. And it connects to most popular training apps, like Zwift, Tacx and TrainerRoad.

1 Like

I am also new, and have my own version of the same problem Ahmed cites. I am using a Kickr bike, unlocked / controlled by APP, paired to Zwift APP in iPad. by Bluetooth with Power Source, Cadence, and Controllable. Height, weight, etc. entered correctly. I am constantly pedaling very fast, yet mostly my MPH speed shows 1 -2 MPH. No matter what the training program, the scenery passes so slowly since the program computes my speed at 1 - 2 and hundreds of other cyclists / avatars are constantly passing me. On the few downhill segments in the training programs, the speed will go up to 10 -20 mph, but then on flats, uphills, and mild down grades, back to 1 - 3. By the end of an hour ride, I am sweating, had a good workout, missed a lot of scenery, and only cycled a few miles with everyone passing me. My typical watts are between 30 - 50. Logic and feel tells me I have cycled 15 - 20 miles during that period.

What am I doing wrong? Am I missing some setting adjustment?


Hi @Glenn_Thomas2 and welcome to Zwift!

I’m not clear on what you mean by unlocked and controlled by APP. Are you connecting it to the wahoo app as well as Zwift at the same time? Have you done a spin down calibration, firmware updates, etc…?

1 Like

Hi @Glenn_Thomas2

Shuji at ZwiftHQ here. Zwift’s real-world feel is predicated on several variables including weight, height, and very importantly, your Functional Threshold Power. It’s the measure of how much power you can can sustain for period of time.

If this FTP number is set too low, you might experience the symptoms you describe. Please update your profile and bump this number up manually to see if this improves your situation?

Assuming this does, it would be a good idea to look for a training plan called Zwift Cycling 101.
It’s a three step workout that teaches you about FTP in general, how workouts are built in Zwift, and ends in a mini “ramp test” that will set your FTP more accurately to your abilities. Look for it here:

Thanks to Mike and Shuji as I work my way through this. I’ve manually updated my FTP in my profile to various values and no difference. Firmware is current I tried to do a spin down test, but it is impossible to get up to 23 MPH. The absolute maximum pedaling speed I can do is about 16 - 17 MPH. Has nothing to do with my fitness or pedaling ability - it’s simply incredibly as fast as one could possibly pedal. So, the spin-down won’t work since I can’t get close to 23. The values shown doing the spin-down are the same issue I’m having with speed during the training workouts - that is the value shown is very disproportionate and much lower than the effort provided. So whatever the problem that is preventing a proper workout speed is the same as doing the spin-down.

I’ve started Cycling 101 as Shuji suggested. Done the first module for 30 minutes. Normal behavior except the MPH low / incorrect speeds as previously cited. I’ll continue to work through the next modules on this program over the next few days.

Meanwhile, I’m still hoping for a magic idea that will solve this problem, as I’m gradual eliminating the surgical suggestions!


Have you contacted Wahoo support? From what I hear in the forums they are really good and will take care of you if the product is faulty.

To what number? 150, 200?

1 Like

Hi Ahmed, it seems like your trainer isn’t properly calibrated yet. I have the same model and calibrate from within the Tacx Utility app. Maybe the Tacx training app does it too.

You need to select resistance level 1 for calibration. Make sure your tyre is properly inflated and pressing down on the roller tight enough so that it doesn’t slip. Then connect your Satori Smart to the Tacx app via Bluetooth and select calibrate, following instructions to speed up to 32 km/h (no more!), then stop pedalling and let the wheel spin down to a stop. If you manage to do all that, you should have a decent calibration, although the app might detect that the tyre is too tight or too loose. In that case, adjust the tightness knob as appropriate and try again.

I’m still quite happy using the Satori Smart though it does have some quirks which can make it transmit power readings that are significantly too high or too low. The trainer (my one anyway) seems to enter calibration mode any time I exceed 32 km/h (I.e. wheel speed on the roller, not in game speed on Zwift). So when I slow down after a hard sprint, it recalibrates wrongly and without my permission. Sometimes I struggle to get anywhere near 100 watts after a sprint, so a proper recalibration is needed. Now I save any sprint to the very end of a ride.

Hope that helps,