Tacx Satori Smart - inaccurate (slow) syncing with Zwift rides?

(Brad) #1

Hi all, new guy here! I have a Tacx Satori Smart and last night was my first time setting it up and riding on Zwift. It seemed as though there was a lag in the connection, is that normal? I was connected via bluetooth to my iPad Air 2. As I would start pedaling it would take a good 8-10 seconds before my avatar would start moving on the screen. Likewise, when I stopped pedaling, it seemed to have a delay. Curious if anyone has any tips on calibration, connection settings, troubleshooting? What are everyone’s thoughts on how accurate it should be if I can get everything setup correctly?

Thanks!
–Brad

(Xavier) #2

Have you checked for firmware updates and calibrated it yet? Nine times out of ten, being behind on firmware, or being uncalibrated, is what causes issues with readings when somebody is using a new trainer.

If you have, it could be an issue with interference; could you try checking for possible sources of interference against this article?

If that doesn’t help, please write in to support@zwift.com with your log files; you can find them by following the instructions in this article.

Ride On!