Weight not syncing from Fitbit [October 2022] [SOLVED]

Thanks @Rowdy this is good news.

That’s positive news. I’ve re-enabled my Fitbit connection (to share weight only with Zwift) and opened the Zwift and Zwift Companion apps, but my weight is still not showing the latest value from my Fitbit account. Is there anything else I need to do to trigger the sync?

Thanks for the update @Rowdy; happy to report that I’ve just done an update to my weight in fitbit and it’s reflected in my zwift profile.

All working for me. Thanks for the hard work solving this.

@CardiffGreens @Diogo_Rodrigues can you confirm if you are doing anything else to refresh your weight in Zwift? Or is it updated simply by opening the Zwift app or Companion app? When you enable the Fitbit connection, do you share just your weight or all data (personal info, friends etc)?

I’ve just checked my settings within Fitbit - it’s showing as “social, profile, weight” being enabled for Zwift.

I was also able to disconnect the connection through the companion app, reconnect it (though it failed on the first attempt for some reason), update my weight in the fitbit app, relaunch zwift companion and have the newly updated weight show in my profile.

I should also mention that I didn’t get the pop up/option to select what I wished to share between fitbit and zwift during the connection process, so I’m not sure how you can change what’s shared.

Thanks! When I enable the Fitbit connection in the Companion app, I’m asked for permission to share different data, as per screenshot. Until now I have only ever selected “weight”, I’ll try selecting all.

Aha! That’s cracked it. Selecting “Allow All” when setting up the Fitbit connection has now sync’d my weight to Zwift.

I’m glad this now works, but I don’t really want anything other than weight sync’d to Zwift, so perhaps something else for support to look into. It’s really not intuitive either, so hopefully this thread will help save others time!

1 Like

It updated only by opening the Companion App.

Connection was setup to share everything (long ago).

When it wasn’t working for you but Zwift had said it was fixed (before you allowed “all”) had you weighed yourself since re-syncing? Don’t know if it takes a new measurement to sync (or just does it once every 24 hours or something). Trying to think of things to test that would allow you not to sync all data.

I did, yes. I tried weighing and re-weighing myself, disabling/recreating the Fitbit connection, and combinations thereof.

Great news, and now works for me as well! Very happy with this.