Weight not syncing from Fitbit [October 2022] [SOLVED]

I have a Withings scale which I sync with a Fitbit account. The Fitbit account is syncing almost instantly. I’ve connected my Zwift account to both Strava and Fitbit. My rides sync to Strava OK. But my weight is not updating from Fitbit. Any ideas? How frequent is the sync from Fitbit to Zwift meant to be; I’d have thought it was instant and/or every time you launch Zwift?

See this recent post from Zwift

Bit of hack via Zwiftinsider here - unsure if it still works.

That’s exactly what I’ve done, but Fitbit is not syncing.

Can you check your connection to fitbit is still up and running - [link to zwift profile connections] - I’ve had it disconnect a few times in the past for no apparent reason.

Also just to mention I updated my weight in the fitbit app this morning and it had immediately updated in the zwift companion profile page, so I don’t think there’s a wider systemic issue.

1 Like

Good to know it should be instant. I checked the connection via the link you gave me, and it appears active.

Only thing I can think of is to try disconnecting and reconnecting the connection to fitbit, updating your weight and seeing if that now gets synced to Zwift?

1 Like

Thanks Colin. Tried deactivating and reactivating the Fitbit connection in Zwift. Didn’t work. Note I’m only sharing my weight, but surely that shouldn’t stop the integration working? Anyone just share weight and has this work. Very annoying!

FYI, weight sync worked just fine for me this morning. Withings pushed a weigh-in to its own app/cloud, which further sync’d to several other platforms, including Zwift.

I would suggest you set up a link to at least one other app - such as MyFitnessPal - to see if the issue is on the sending or receiving end. While you’re at it, ensure you don’t have any firewalls or blocker apps like “Blockada” preventing a sync - whitelist all the fitness apps (Withings, Fitbit, Zwift etc).

Further, if you’ve updated any apps or your OS lately, check permissions. If on Android, UN-check “remove unused permissions” - my experience with that one is it tends to be bossy and removes things I want left alone.

Thanks CJ. Hadn’t thought about as blockers, had assumed the integration was cloud to cloud. I’m using AdGuard for my DNS, so checked the logs and it appears the Zwift Companion is trying to communicate with a couple of blocked sites (see screenshot), which I’ve now unblocked. Still no luck.

I’ll also try connecting with another app as you suggest.

Just noticed that on zwift website, the weight field (in kg) does not support decimal places. Whereas in the app decimal places are shown. So I wonder if one of the methods above has solved the syncing, but I’m not seeing an update in the app due to rounding. I’ll set my weight to 1kg higher then try to sync again.

1 Like

I’m having the same problem. Just noticed that a few days ago (maybe 4 or 5) Fitbit stopped syncing my weight to Zwift. Already disconnect and connected again and sometimes it updates after but the next day it’s broken again.


Same issue for me, weight from Fitbit no longer updates to Zwift as of last week.

1 Like

Same issue. It was working flawlessly then stopped. If I disconnect and reconnect, it syncs once then stops.

1 Like

This did not work BTW. I’ve just had to abandon this for now as I assume it’s a bug. Hopefully Zwift will fix this issue at some point.

1 Like

Same here. I get one sync after a disconnect/reconnect and then it freezes again. The fitbit hack was good for a year, but now it looks like they’ve broken something else.

Withings connected to Fitbit still sync for me.

EDIT: Apparently I weigh the same as when it got stuck… So minde does not update.

I usually update my weight directly through fitbit - just checked and it’s not updated my weight in game for about a week - I removed my connection via the zwift profile and it took 2 attempts to go through the full connection process before it would show as connected within my zwift profile - after the first attempt it’d complete the process, but visiting the connections page would offer the options to reconnect fitbit; after the second attempt everything was fine (and my weight would update at that point, but it wasn’t pulling any changes in the fitbit app through again).

For my own interest this whole “takes two attempts to complete the connection” also happened if I disconnected the connection, completed 1 connection attempt in the web, then fired up the companion app and viewed my connections (fitbit again showing as unconnected) - completing the connection process through my phone would then keep it connected.

1 Like

It also took me a number of tries to get it reconnected (and then it only synced that one time before stopping). I wonder if the trouble reconnecting is somehow related to the lack of sync-ing.

Are the others of us who only get the one sync after reconnecting also having trouble getting the connection to register again after disconnecting?

I am seeing the same issue with MyFitness pal and Todays plan, my assumption is it is a Fitbit issue

Same issue here too. Fitbit shows connected, but weight (which has decimal places in ZwiftPower) hasn’t updated since Oct 25.